AOE IV Support for M1 MacBook Pro's - Does it work?

2 Subjects in this topic, in short:

1. Mac-support for macOS/M1-Macbooks please

2. Did someone manage to make Age of Empires IV running on a MacBook Pro M1 (Pro/Max)?

Topic 1. Mac-support cry-out:

I know many of you will disagree with the fact that Age of Empires (I, II, III or IV) has to be made available on the Macbook Pro’s with an M1-chip. But since the lines are fading between consoles and pc’s with more cross-play compatibility and since Windows is rolling out to ARM-architecture pc’s as well, isn’t it the perfect time for Microsoft/Relic to consider a rollout of the AoE franchise back to the Mac? Just like the old days when AoE II and AoE III were released on OS X as well?

I still hope that one day we’ll see this announcement, especially because I’m hyped for Age of Empires IV as well. But since my workflow is completely macOS-based, I’m not considering to buy a pc just for one game. And since Windows/Apple both decided to give bootcamp a silent death on M1-macs, I’m pretty much out of options.

Topic 2. Age of Empires IV on M1 (Pro/Max)

Gaming through crossover/parallels don’t seem to be worthy options, but nonetheless… If some of you got AoE VI working, please do share it in this topic. How did you manage to make it work?

9 Likes

No.

Age of Empires 4 needs the AVX CPU extension and M1 chips don’t have it. And there is no way to emulate that.

You can play AoE1-3DE using Rosetta 2 and Steam Proton but that won’t work for AoE4 even on an M1 Max.
Older Intel based Macs (or AMD hackintosh) will likely run the game at last after some updates to Proton.

3 Likes

If the game is available in Geforce Now or Xbox Cloud Gaming that might be an option. But no AOE game is currently available in those platforms. So little hope.

I would also buy this game immediately if it was available for my new MacBook Pro with M1 Pro processor. My 16 GB RAM and the GPU & CPU performance should be more then capable of running this game smoothly. I understand that AVX instructions are for x86 and are not available on ARM64, but if Microsoft really takes ARM (and me as a potential customer) seriously, they could find some solution to make this game work on ARM as well, in a way that Windows ARM can run the game.

Then, they just need to license Windows ARM to Macs (licensing is currently the only reason holding off Windows from running natively on M1 Macs according to Apple) and I can buy and play this game on this amazing laptop, that I believe many people will buy in the coming years. It’s such a silent powerhorse with long batter-life that this hardware’s success is inevitable. That’s lots of potential gamers.

6 Likes

See an extended discussion of this issue here: https://www.reddit.com/r/aoe4/comments/qgs5l8/aoe4_on_an_m1_mac_with_parallels/

1 Like

+1 on this. Age fan, buyer for sure. Can play all age of empires games (and many others) on my M1 (using either Parallels or Crossover) but not AoE IV because of AVX restriction.

It’s not just M1, but also M1 Pro and M1 Max which are brand-new machines more than capable to run AAA games.

3 Likes

Same here. I just bought the game and now I realize it not compatible with my M1 Mac. What a shame!

1 Like

You must release AoE IV at least on Windows 11 ARM so we can play it through Parallels virtualization.

You have no excuses since Apple Silicon, especially M1 Max is the best SoC in the world EVER.

3 Likes

Ditto would absolutely love a port to the Macs M1 or at least make it playable in Windows ARM so we can emulated

2 Likes

Has anyone even brought up Linux? Kinda wondering if steam proton has it covered.

Welcome to the forums, homie.

An official port to ARM Windows would be very welcome. The other AoE definitive edition games play great on my M1. I think AVX may never be emulated due to Intel not allowing it.

So it doesn’t work at all on your M1 macbook?

@SidewardLake76 (forgot to tag you)

@ThePokeChim It doesn’t launch at all from Parallels on Apple Silicon. It complains about lack of AVX instructions. Same issue with ARM-based Microsoft Surface. Hopefully they remove this dependency or do an ARM port…, but nothing yet. I’m planning to pick up a Steam Deck just for this game.

1 Like

Have you tried running it with the -disableCPUextensions flag?

Really sad, that there is still no solution for M2 Pro via Parallels. I’d really like to play AoE 4, but need to have a mac for work (and don’t want to have another machine)

How is that be done?