AOE IV will not recognise previous gameplay, on start

Every time I start AOE IV, I have to reset the preference settings, then I am returned to the very start of the game. My previous progress (Campaigns, Art of War, etc) is not recognised.
All files, including auto save files are exactly where the game has put them (why they’re stored in My Documents by default, I don’t know!), but I can’t retrieve them via the game.
If I try to “Load a saved game”, the pane is empty. Essentially, the game doesn’t appear to know where it put its stuff!
I have tried uninstalling, deleting all files and reinstalling, but nothing has changed.
I installed the game from XBOX GamePass for PC.
I also tried changing the target install location, via the “Manage” button on the XBOX App, but the game still auto saves to My Documents, so I have files in 2 separate locations!
No issues, while I’m actually playing, but getting tired of having to play “The Normans” campaign every time I want to try something else!
Playing on Lenovo Ideapad 510-15IKB,Windows 10 v 1909, 20GB RAM, intel i5-7200U 2.70GHz. HDD 906GB - with 568 free

@MorgurthT sorry to hear you are running in to this. First thing I would do is make sure your My Documents folder is not backing up to someplace like OneDrive, Dropbox, etc. I believe that’s caused problems in the past. Second thing I would do is contact support with your warnings.log file. Hopefully they will have some tips that can help. If you do figure this out, consider posting the solution here so others can see.