AOE2 DE lagging/stuttering

You can upload them to a folder in your drive/dropbox or any other similar tool and share the link please

1 Like

Thanks for the reply.

The link:

I only added the log from around 3 p.m., when I last played.

It was an unranked online 1v1 game.

There is also a slowLog.txt and a main.txt (in a folder) with that time stamp. Do you need these too?

If anyone is interested in this topic, the stuttering stopped for me.
But I am not exactly sure what caused it and why it is now fixed. I tried several things like reinstalling on SSD and ISP related stuff.

The game did not receive an update so I assume that it was an issue at my end. Seems like it was an error that accured at the exact same time as the last patch. It might just have been coincidence.

Kind regards

Please help me i have same issue suddenly.

i recently upgraded from ryzen 2600/vega56 to ryzen 5800x and 6700xt.

But somehow the game performance is terrible now! Fps goes to like 1-4 sometimes in multiplayer, all game freezes for few seconds and then runs again. Not sure if its the new patch (i havent played months) or something with new pc? I tried reinstalling and disable all mods but nothing… its unplayable. :frowning:

2 Likes

I have the same issue for about 2 months now. I stopped playing since it is no fun anymore this way. Hoping it gets fixed soon.

1 Like

Hey everyone,
if you still have similar issue please try to use the enhanced logs build: 📌 [HOW TO] Use the Enhanced Logging Build to generate Networking Logs (Disconnects)
And then follow instructions of AOE2 DE lagging/stuttering - #8 by DirefulLily9407.
Thanks for the help

same issue,after some minutes of gameplay it starts lagging and just stops completely.
only mouse moves and nothing else.This started to happen recently ,game worked fine before for me.maybe new update caused this.

1 Like

Same problem.

Game stutters nearly CONSTANTLY.

AMD R9 5900x
AMD RX 580
16GB

Here’s the log

I have tried every suggestion I could find to solve this, I have put it on an NVME SSD, disabled antivirus, played on minimum settings, updated my gpu drivers, disabled my internet adapter, nothing works and the game is borderline unplayable whenever I get more than 10 minutes in.

However, it works PERFECTLY on my much older, much weaker laptop (i5 2520m, nvidia 650ti).

3 Likes

That looks like this bug to me:
https://forums.ageofempires.com/t/frame-time-bug-micro-lag-performance-issue-video-stutter/

But it can also be an issue were the game simulation holds all the time, I can’t tell bc the video is low fps.

edit: I am referring to the issue of @Sel5951 only, not to the thread creator.

1 Like

Thanks for the logs, i have forwarded to our team. :slight_smile:

1 Like

I tried swapping view modes to see if it did anything but no dice. I’m leaning more towards the game just not being able to keep up because I played a smaller game with a friend before this and the same issue occurred just not nearly as severe and since it seems to momentarily speed up to catch up between freezes.

@Sel5951 I think it’s caused by the AI or a faulty client by a match participant. I can’t recall exactly, but I saw this kind of lag already.

Try to play a 1v1 vs an AI.
If the lag does occur change the AI.
If the lag doesn’t occur try to play online on a server vs the AI.

If that also works, try to play against a friend.

I hope you can find what’s wrong, good luck :stuck_out_tongue:

I had this problem too, my game was freezing for a few seconds and then quickly catching up.
Tried everything removing mods, reinstalling, checking ports, etc. and nothing worked.

What was causing this in my case it was my anti-malware Malwarebytes. It seems that it keeps scanning the game even if you play offline.

Anyway, after whitelisting AOE 2 DE folder in Malwarebytes, the game ran smoothly again.

Can’t take full credit though, I got the hint from this Reddit post: https://www.reddit.com/r/aoe2/comments/o0zvxo/solved_age_of_empires_2_definitive_edition/

Hope this helps

2 Likes

Whitelisting AOE2 DE’s folder on malwarebytes solved it for me too.

Had this same issue running a high end PC… can confirm Malwarebytes was the culprit in my case too, and whitelisting the AOE2DE.exe was the answer. Thanks to those of you who solved this issue.

More details please - what do you mean with malwarebytes? I don’t have a programm installed with that name. I already added steam folder to my nod32 and the problem is still there.

Its an anti virus/ anti malware app that you can choose to install. It’s possible that other similar apps with the same file scanning feature as Malwarebytes could also cause this issue.

1 Like

I was bummed that I kept having stuttering issues during 1v1 AI skirmish and during campaigns. This really helped me in removing the issues I faced; I was on Malwarebytes too. Thank you for this solution.

Occasionally having the same issue here.
It is quite a bit revolting that a game from 1999 still has such performance issues.
Sometimes, only sometimes, in a multiplayer match, my user icon has the red globe besides it which in such occasions seems to suggest that it is a network issue, but it isn’t. Today it occurred and my network connection is as strong as ever. Download speed at 345 Mbits/sec and Upload at 163 Mbits/sec, ping is at 5msec.
Can’t really understand this.

In the episdoes that still stutters but has no red globe icon besides me, it is more constant thorughout the match and it worsens if I click at any unit our building or give any order.
Specs: Ryzen 9 HX5900, 32Gb Ram, HD6800M, 1,5Tb SSD.

Thank you very much for this solution! It was Malwarebytes for me as well!! I spent so many days with lagging game… but now finally back to normal

1 Like