AOE2 DE lagging/stuttering

AOE2DE Steam July 2021

Every game I play online/offline has freezes/lags for very short amounts of time and seem to get slightly longer to ~2 seconds as the game gets longer/larger. They happen randomly, usually no more than 1 every minute. I can move mouse but nothing else.

Ive wiped mods, played on low settings, reinstalled and played with hardware monitors open and found no hardware spikes or caps. No issues with other games atm.

Age of Empires II Definitive Edition 2021.07.27 - 20.13.38.03.DVR_Trim short clip from my testing.

2 Likes

Fine for me. Seems more like performance issues than a bug.

Huge lags after the new patch - #14 by Hjoerleif this post from last year made me think its the same issue so i submitted as a bug.

1 Like

I am experience soomething similar. The lagging start abou 10 minutes into the game. If i click the mouse more that 4 or 5 times, I get a mesage saying the app has stop reponding, do you want to wait. AT that time the game will never resume. You just have stop.

During this time the music continues toplay but i is ‘scratchy’ or ‘staticy’. Also if you make threw the game and exit at the main, the muisic continues for xeveral seconds after the AOR window closes.

The stuttering and scratchy sound has been occuring for several months off and on. Sometimes an update fixes the bug but then a future update reinstates it. I checked my vertual memory snf it is not fcompletely used.

Similar, but mine never crashes and the sound only pauses.

After my lags It just speed catches up for a moment in online like normal lag, or resumes play in offline like the vid.

If its a performance issue id love some ideas of what to check because ive tried everything i know.

This is a known issue and is currently being investigated. Thanks for the information!

1 Like

Thanks for the reply. I didn’t get it at all today and im pretty sure it started at the last map rotation, 100% every game. Its gone for me after the new maps today so I guess the rotation broke something.

@sanik00 @ReTuRnOfpRaCtIs @LayeredGoat6613 if you ever experience this issue again, you can press “ctrl+break” right when the freezes happens and it will generate some files in %USERPROFILE%\Games\Age of Empires 2 DE\logs folder. Then please attach those files (logs and minidumps) that would be really helpful. Thanks a lot!

1 Like

Hello Devs,

I also experience the stutter lag, which i never had in over one year and suddenly appeared a few days ago. I only experience these lags in Online gaming. I have no problems against bots. Stutter lag means, the game freezes and then speeds up to the current game time again. It is absolutly unplayable for me right now.

I tried to press “ctrl+break” and I could upload some files from the log folder but I am a new user and I am not allowed to upload.

Is there any other way I could send you the files?

You can upload them to a folder in your drive/dropbox or any other similar tool and share the link please

1 Like

Thanks for the reply.

The link:

I only added the log from around 3 p.m., when I last played.

It was an unranked online 1v1 game.

There is also a slowLog.txt and a main.txt (in a folder) with that time stamp. Do you need these too?

If anyone is interested in this topic, the stuttering stopped for me.
But I am not exactly sure what caused it and why it is now fixed. I tried several things like reinstalling on SSD and ISP related stuff.

The game did not receive an update so I assume that it was an issue at my end. Seems like it was an error that accured at the exact same time as the last patch. It might just have been coincidence.

Kind regards

Please help me i have same issue suddenly.

i recently upgraded from ryzen 2600/vega56 to ryzen 5800x and 6700xt.

But somehow the game performance is terrible now! Fps goes to like 1-4 sometimes in multiplayer, all game freezes for few seconds and then runs again. Not sure if its the new patch (i havent played months) or something with new pc? I tried reinstalling and disable all mods but nothing… its unplayable. :frowning:

1 Like

I have the same issue for about 2 months now. I stopped playing since it is no fun anymore this way. Hoping it gets fixed soon.

Hey everyone,
if you still have similar issue please try to use the enhanced logs build: 📌 [HOW TO] Use the Enhanced Logging Build to generate Networking Logs (Disconnects)
And then follow instructions of AOE2 DE lagging/stuttering - #8 by DirefulLily9407.
Thanks for the help