AOE2 DE lagging/stuttering

@Sel5951 I think it’s caused by the AI or a faulty client by a match participant. I can’t recall exactly, but I saw this kind of lag already.

Try to play a 1v1 vs an AI.
If the lag does occur change the AI.
If the lag doesn’t occur try to play online on a server vs the AI.

If that also works, try to play against a friend.

I hope you can find what’s wrong, good luck :stuck_out_tongue:

I had this problem too, my game was freezing for a few seconds and then quickly catching up.
Tried everything removing mods, reinstalling, checking ports, etc. and nothing worked.

What was causing this in my case it was my anti-malware Malwarebytes. It seems that it keeps scanning the game even if you play offline.

Anyway, after whitelisting AOE 2 DE folder in Malwarebytes, the game ran smoothly again.

Can’t take full credit though, I got the hint from this Reddit post:

Hope this helps


Whitelisting AOE2 DE’s folder on malwarebytes solved it for me too.

Had this same issue running a high end PC… can confirm Malwarebytes was the culprit in my case too, and whitelisting the AOE2DE.exe was the answer. Thanks to those of you who solved this issue.

More details please - what do you mean with malwarebytes? I don’t have a programm installed with that name. I already added steam folder to my nod32 and the problem is still there.

Its an anti virus/ anti malware app that you can choose to install. It’s possible that other similar apps with the same file scanning feature as Malwarebytes could also cause this issue.

1 Like

I was bummed that I kept having stuttering issues during 1v1 AI skirmish and during campaigns. This really helped me in removing the issues I faced; I was on Malwarebytes too. Thank you for this solution.

Occasionally having the same issue here.
It is quite a bit revolting that a game from 1999 still has such performance issues.
Sometimes, only sometimes, in a multiplayer match, my user icon has the red globe besides it which in such occasions seems to suggest that it is a network issue, but it isn’t. Today it occurred and my network connection is as strong as ever. Download speed at 345 Mbits/sec and Upload at 163 Mbits/sec, ping is at 5msec.
Can’t really understand this.

In the episdoes that still stutters but has no red globe icon besides me, it is more constant thorughout the match and it worsens if I click at any unit our building or give any order.
Specs: Ryzen 9 HX5900, 32Gb Ram, HD6800M, 1,5Tb SSD.

Thank you very much for this solution! It was Malwarebytes for me as well!! I spent so many days with lagging game… but now finally back to normal

1 Like