AOE2 DE Multiplayer Launch Screen Freeze Some Players Drop Some Stay Upon Start

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD #age-of-empires-ii :
  • GAME PLATFORM: Steam / Microsoft Store
  • OPERATING SYSTEM: Windows 11

:arrow_forward: ISSUE EXPERIENCED

After launching a hosted game from the multiplayer lobby, the launching screen comes up and it appears to remain frozen for a very long duration of time. I notice that the fire sparks do not float across the screen and usually other players will drop once the game finally loads and enters into the game. There seems to be an issue or a huge delay in loading multiplayer games. Once in the game I can continue to play normally as expected however it is extremely frustrating that other players drop upon the startup after a long delay load time.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!
100% of the time

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: ############ STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Host a lobby. I am from the Midwest region Minnesota if that matters?
  2. Game settings I usually use are 40min. treaty, ludicrous, explored, high resources, locked teams, empire wars mode, normal speed, pop 400, map Amazon Tunnel, usually a 4v4 matchup.
  3. wait for all players to hit ready then click the start button and see if it will load normally. It doesn’t for me ever. And I have tried many things like updating my Microsoft computer, re-downloading the entire game from Steam, checking my firewall settings, updating my graphics driver. My computer purchase is fairly new, not an outdated computer, and it has plenty of memory space left. I have tried altering and lowering the graphics settings, playing in other game modes and different maps, map sizes. nothing seems to work and I am tired of failing to resolve the issue myself.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game is supposed to smoothly load and transition into gameplay at the startup. I should see that the game launch load screen is producing moving fire sparks, not frozen ones. Multiplayer gameload time usually used to be no longer than 2 minutes but now it seems painful at sometimes 5-8 minutes if lucky.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

I’ll be honest, I was surprised. When people put their title in all caps, I usually expect their post to be screaming in caps lock, which isn’t very nice to read. Glad to see that isn’t the case.

Hi @Babbl1ngBabo0n
There’s an issue with loading screen for some people, if it happens that they click repeatedly, the game might crash.