AOE2: DE Performance drop after first AOE2 start and continue slow after that

:arrow_forward: GAME INFORMATION

  • Build: 101.101.37906.0
  • Platform: Microsoft Store
  • Operating System: Windows 10
  • Gamertag: eLEcTRiCZiTy

:arrow_forward: ISSUE

A few days ago, I installed and played AOE2: DE. Everything was smooth and OK (Ranked Benchmark Test score unknown). But yesterday, the game starts to lag, and performance rating drops to ~718 (Ranked Benchmark Test).

I discovered, When I start the pc, then AOE2 starts fast, and intro cinematics runs fast and smooth. After that, I try to start the Ranked Benchmark Test (RBT) or regular Single Player game. When the game begins, the performance of the AOE2 drops down a lot. Every time after when I start AOE2, then intro cinematics lags like ■■■■ and sparks in the game menu, menu button response (highlighting), etc. are laggy too. After this, AOE2 is unplayable (estimated ~5 FPS, 10FPS max). Change of game settings did not affect FPS or RBT score. Only switch the game to the window mode and resize the game window to the smallest size changed performance a bit (RBT ~1100). But overall performance is all wrong.

I have Surface Book(1) with Performance base (i7, 16GB RAM, NVIDIA GeForce GTX 965M).

:arrow_forward: REPRODUCTION STEPS

  1. Start PC (clean start, no stream client started, no other apps)
  2. Start AOE2 (in fullscreen)
  3. The intro is smooth, game menu respond fast
  4. Start a Single Player game or Ranked Benchmark Test
  5. Once the game starts, you can see that a few seconds are running properly (fast, smooth, as usual). After that, it suddenly slows down and stays in that kind of performance.
  6. After the end of the test or after quitting the current game, the game menu is laggy too, and each started game starts slow.
  7. After closing of AOE and starting it again. The intro cinematics is laggy (sound too), the game menu is laggy, and games are choppy slow-motion.

:arrow_forward: GAME FILES

Nothing usable.

:arrow_forward: IMAGE & ATTACHMENTS


1 Like

Maybe game started to use integrated graphics card instead of dedicated graphics card for you? Some people who reported very sudden huge drop in performance had this problem

Today I tried it again… and the problem no longer exists. :thinking: AOE2 runs smooth as usual.

I hate problems that solve themselves without knowing how or why.

@Yorok0 Anyway, thank you for your reaction.

Using the charger on your laptop will use dedicated graphics which will give better performance than integrated graphics (without charger).

It probably depends on power settings

1 Like

No, power settings are not responsible for my earlier problems. AOE2: DE runs on battery on NVIDIA GPU, and the RBT score is slightly lower (~1050). On charger, it runs on NVIDIA too, and the score is higher (~1100) because of no need to save power.

When the problem occurred earlier, the game was slow, although according to the task manager, and CPU consumption and GPU consumption was around 60% (I really do not remember if game runs on NVIDIA GPU :disappointed:).

Now, when I run AOE2: DE and run the RBT benchmark, the game goes smooth. Even on the battery, the game runs with both CPU and GPU consumption below 50%, and the resulting score is close to 1100. (Surprisingly, the score dialog screen runs at 91% GPU consumption :smiley: )

Maybe earlier the game switched to Intel GPU for some reason. But it’s not happening now.

The first row in the Task manager is the AOE2:DE and GPU-1 is Nvidia GPU:

If I find out anything new about this problem, I’ll write it here. So far, the problem is probably solved.

Even on Intel GPU and on the battery the game runs well :sweat_smile: GPU-0 is Intel GPU.

1 Like