Aoe2 Multiplayer Features Don't Work (Chat, Browsers, etc.)

Game Version:101.101.35584.0 4714640

  • Build: Dunno. I listed the version number on main menu.
  • Platform: Steam


Nothing that is multiplayer related works except for the queue ranked button and matchmaking.

Essentially, I cannot use any multiplayer features. I can’t type in multiplayer chat. I enter my message into the entry box and it does not send. I also do not receive incoming chat. I cannot load games in lobby browser. I also cannot load spectate games browser. Crossplay is enabled. I have attempted removing all mods and I have attempted waiting for a new patch to fix this. I’ve had this issue since last update. (The March 12th update did not fix it.)

Nothing on my end has changed whatsoever. I used to be able to play this without a problem. I have the same router, same ISP, same modem, same hardware. Same account etc etc etc. Nothing on my end has changed. I simply logged on one day and nothing worked.

Reproduction Steps:

I honestly can’t tell you how to reproduce this. I’ve tried uninstalling the game, reinstalling, verifying game files through Steam. Nothing seems to work.

UPDATE: 3/1/2020

I fixed it by signing out in the top right. This is reproducible now. Signing in disables all my multiplayer features that I listed. Signing out re-enables.


I have the same issue in multiplayer with chat. I know other users have it too. I’ve removed all mods and reinstalled the game but cannot see ingame chat. I can type in chat window but nothing appears, cant see opponent or teammate chat either. Can hear audio taunts only.

Have seen other users with issue here:

I have hypothesis it could be issue with widescreen resolutions?

It might be caused by malfunction of recently added profanity filter, which tries to filter everything you write.

1 Like

logging out and back in of xbox live seems to sovle it :slight_smile:

Game Version:

  • Build The latest as of 2020-03-02
  • Platform Steam


  1. I can’t see the chat when playing a multiplayer game. This happens 100% of the time. I CAN see it in single player standard games 100% of the time.

  2. A bunch of other issues. Mainly crashes immediately upon starting a multiplayer game. This happens roughly 66% of the time I try to start a multiplayer game. It appears as if the success rate increases if I start a single player game first. As if the loading of the assets once helps. It’s far from 100% though.

Reproduction Steps:

  1. Come over to my place
  2. Start my computer
  3. Start a multiplayer game in AoE2:DE
  4. Fail to see the chat.


1 Like


Sign out of Xbox live.


Boom! Done! Thank you!

1 Like

Hello everyone! For those of you experiencing issues when signed into Xbox Live, can we please get a video highlighting the problem? Ideally, it should include:

  • What it looks like when signing in.
  • Issues you see when signed in.
  • What it looks like after you sign out.

This will help our QA team investigate the issue and help ensure that this doesn’t happen again.

Thanks for the reports!

Exact same issue - signed out of xbox live and it worked immediately. Silent crossplay exception?

Essentially the lobby browser just says “Searching for games…” indefinitely.

Fresh install as well. I recently signed back into xbox live after the update if that helps.

1 Like

I will be doing some testing tomorrow afternoon to try and attempt to give myself the bug again. I have a very strong suspicion that what likely caused it is changing my Microsoft password through a related Microsoft website while the game was open and I was signed into Xbox live in the AOE2 client. I will update this post when I get the chance to do this. Tomorrow afternoon. I am PST timezone.

EDIT: 3/6/20

Changing password did not cause the bug. I’m not sure what causes this bug where games do not load and spectate games do not load and chat is unusable. But it is 100% fixed by signing out of xbox live. (You can sign back in afterwards usually and it may or may not give you the bug again.)

Is there any chance you can capture a video of the issue—highlighting the problem while signed in vs. signed out—that I can pass along to our QA team? This does not appear to be a universal problem, so we’d like to see what you’re seeing!

Thank you! Problem solved :clap: