AOE2HD Rise of Rajas.exe.system

AOE2HD Rose of Rajas Exe.system.

I am having some problem with AOE2 HD rise of rajas.exe system,and this is what its says
The code cannot proceed because twitchsdk_32_release_dll was not found.Reinstalling the program may fix the problem

The code execution cannot proceed because zwibwapi.dll.was not found reinstalling the program might fix the problem.Where can I find aoe2hd rise of rajas fixed version with all files for playing and fixing the bug on aoe2hd rise of rajas.Expansion oe :aoe2 hd forgotten kindom,and aoe2 hd african kindom,and rise of rajas aoe2hd exp.Sorry for spamming the forum.KIND WISHES AND BEST REGARDS

This even happens when I’ve downloaded Steap appi.dll,I have logged out of rise of rajas2 hd pressed desktop shortcut for aoe2hd rise of rajas to play again could not start it two exe system errors occured same thing happened when I reinstalled aoe2hd rise if rajas.

Have you tried downloading those two dll’s you mentioned and moving them to the HD folder? Have you played HD without issue previously?

Also, this is the II DE forum. For the HD forum I suppose you should go to Legacy, but let’s stay here. I guess here you should have more visibility.

This would be my advice

Get DE, it’s far better than HD in every way.

What is your advice,I have tried everything,nothing worked

He said ‘get DE’. So, did you have those issues before?

This honestly sounds like a cracked issue.
Noone else needs to download a steam dll.

So my sollution is: BUY THE GAMES YOU WANT TO PLAY

1 Like

Can any one show me how to fix the bug or even tell me where to put the fix?

Shall i put it on where the reddist is?

Or to copy and paste to Common Redist where is Direct x

Again, did you try downloading those DLL? Did you have that issue previously? Do you have a lega version of the game?

I have downloaded tried to fix watched it on youtube did exactly as a fellow player did reseted the game nothing happened.It was blurry could not see nor do it correctly.Can you show me how to fix it thanx?

This is how I have followed instruction to fix the buggs

Exactly as this fellow

Sorry for spamming the forum.I will record it when I get my self a new cellphone,my mom took my cellphone from me.

We can’t help you if you don’t answer the questions, then.

Sorry and good luck

I have already answered you.I have downloaded and tried to install by copy and paste.Nothing worked

Both dll’s?

Also, do you have a legal copy?

Can you maybe provide a screenshot of your Steam library so we can be assured that you own a legal copy of the game?

Edit: you can buy the most recent version of AoE 2 here

hey Abiding.

you should be able to fix the issue simply by reinstalling steam since the dll files should be related to steam. uninstall the game and steam and then reinstall steam and then the game through the steam library.

Can you play without steam?