(AOE3 DE) DX11-related hard crash

:arrow_forward: GAME INFORMATION

  • BUILD #: 100.12.1529.0
  • PLATFORM: Steam
  • OS: Windows 10

I will provide my computer specs for your reference:

:arrow_forward: ISSUE EXPERIENCED

I was playing in a 1v1 skirmish against the Hard difficulty CPU. The game crashed with a DX11 error at a seemingly random time.

:arrow_forward: FREQUENCY OF ISSUE

Less than 25% of the time / matches I play (RARELY)

:arrow_forward: REPRODUCTION STEPS

It’s not a consistent issue to reproduce. I have completed multiple games, this has only happened a couple of times across over a dozen games, both in multiplayer and single player. The map and civilizations have been different each time, as far as I can tell. On this particular instance, it happened on a snowy map against the Chinese while I was playing as the British. We were both in the Commerce Age.

:arrow_forward: EXPECTED RESULT

The game would continue uninterrupted.

:arrow_forward: ACTUAL RESULT

The game froze for a few seconds, then went black and the error message appeared. Clicking OK closes the error and the game.

:arrow_forward: IMAGE & ATTACHMENTS




I get this error all the time on my 2080Ti. It seems like we share the same graphics card. I’m running the game on all medium getting 60fps throughout. I have no idea why this error happens on our graphics card. This has been going on since launch for me. My ranked win% is god awful because of all the games it’s booted me from. So damn frustrating. I love this game, but how many times can you be booted out in ranked while winning that you just uninstall?

That’s interesting, because I run the game perfectly well on maximum settings. The performance (framerate) has been just fine, but anytime this error comes up and crashes my game it really bugs me.

I get the same error resulting in a crash to desktop on a gtx 1660 super. Happens maybe every 1/50 games.

I had an identical problem! It ended up being an issue with my laptop where my machine was switching from integrated graphics to the graphics card even when plugged in. I fixed it by going into graphics settings in Windows and adjusting the settings to only use the graphics card to run AOE3DE. You select the program and then switch it to “High Performance”