Art of War challenges are bugged

Game Version:

  • Build (34699)
  • Platform (Steam)

Issue:

Art of war challenges are bugged in different ways.
Booming challenge- Building a University, Monastery or siege workshop does not allow for advancing to Imperial age. The upgrade button just doesn’t appear. However it does if using castle method. Makes for a very hard challenge this way.

Rushing the enemy challenge - First 3 villagers killed every time are not counted towards the 5 villager kills. (I feel you could up this challenge to 8 villagers to kill anyway for Gold medal as i managed 10 kills after a few shots)

In Defending against a Rush - The enemy melee units jump through buildings and palisade walls after hitting for a while. Which is rather counter productive.

Reproduction Steps:

  1. To recreate, just do the Art of War challenges, it was the same bugs every time as explained above.

  2. Booming challenge, create 100 villagers a university, monastery, siege workshop and the imperial age upgrade in the TC will not show. But build a castle after building 100 villagers and it does work.

  3. Rushing the enemy - kill any 3 villagers on the map, i tried with both scouts and archers. The first 3 villager kills are not recognised.

  4. Defending against a rush - start by palisade walling or housing off each open section in the trees. If you need to, repair the palisade or house and the melee units will jump through the building.

(ATTACH A SCREENSHOT IF YOU ARE ABLE!) Sorry cant screenshot but have tried to explain

11 Likes

Can confirm that the rushing the enemy one is still in effect. Haven’t tried the others. Also, it seems that the challenges should start with a video or something but it doesn’t show. I can only hear the sound.

1 Like

I just came across this bug, and I could not upgrade to imperial age without creating a castle.

I’ve experienced the Rushing the Enemy one described as well!

I have the same problem with all the listed missions.
It is quite annoying if you want to learn how to get better and the missions are not working properly…
This needs a fix asap imho.

I experienced the same two bugs: The first three vils don’t count and I wasn’t allowed to advance to Imp with much more than 100 vils, university and monastery. #feelsdautman

i had the same issues, the 100 villagers challenge is really annoying, and its again imposible to finish a cmpaign :frowning:

Bug is still there, in Rushing your enemies challenge, first three enemy villagers are not counted.

Game version: 101.101.35209.0.4667120

First screenshot is when I killed first two, second screenshot when I killed next three (five total): https://imgur.com/a/id5jDJs

In Booming challenge, you need to build a Castle, not a “two castle age buildings” (I’ve built University and Monastery) in order to even have the option to click on Imperial Age.

How has this not been fixed yet? It’s probably just a trigger thing and it’s kinda frustrating for new players.

Do you guys have any plans in the slightest to fix the art of war tutorials?

The booming one has been bugged for months now and hasn’t been addressed in any patch notes.

The rushing one is also bugged.

I’m experiencing the same issues in the “Rushing the Enemy” and the “Booming” challenges. Hoping for a fix soon

The booming challenge is still bugged which is a shame because they are actually pretty good for learning and practicing.

There is a developer reply on steam that both the booming and rushing your opponent problems are known, and a fix is in the works.

Still is to this day

Echoing this sentiment: the team is on the case! If these issues persist after they fixes have been implemented, please feel free to open a new thread so we can submit a new thread to our development team! =)

Game Version:

  • Build: 101.101.35584.0 4714640
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Collaide

Issue:

In the scenario ‘Art of War: Rushing the Enemy’ killing some villagers don’t count towards the goal.
It tends to be the first few, but occationally happens later.
In Screenshot 1 the first 2 villagers I killed didn’t register.
In Screenshot 2 the first 3 villagers I killed didn’t register.
Another time I killed 8 villagers yet only 4 counted towards the goal.

Reproduction Steps:

Here’s how to reproduce the problem:

  1. Play the Scenario.
  2. Kill a villager.
  3. Check if every villager you kill adds to the count.
  4. If it works as intended, keep killing villagers and see if you notice a kill that doesn’t contribute.

ATTACHMENTS:

  1. (https://i.imgur.com/kW9sZKz.jpg)
  2. (https://i.imgur.com/CXgipai.jpg)
2 Likes

Happened to me as well. Typically it was the vills on gold.

1 Like