[ASKING] Why some animation's not loaded correctly in granny viewer?

When I open gr2 model and animation files in Gr2viewer, the animation are not loaded correctly, only the reorient bone is moving, other bone are not.

The model I view is DoppleSoldier, and I can only view his cover idle pose.
I haven’t tried with other model though.

Btw, I was trying to view and edit model of AOE3DE in blender, I used Noesis and gr2 script to view and export model/animation to other format, when viewing animation in Noesis, the animation show un-correctly, so I open them in GR2viewer and they showed the same result.

If anywho can help me or correct if any other step I need, very appriciated. Thank you in advance.

I just tried with steppe and his animation are viewable in gr2viewer. Maybe some are viewable and some are not.

It could be, that some models are legacy and have some small difference in it

1 Like

Also encounter this issue. Only cavalry type unit’s animation works fine.

Yes, and some villagers, some walking,death animation is able to work.

I tried with legacy version animation and the animation work for almost of the units, it’s just that the animation look kinda weird in blender.

For my method, I use Noesis and gr2-script to export the armature and animation of legacy version, then I match the DE model with exported legacy animation.

Just let you know, I have resolved the issue, I am now able to import DE animations. I looked deep into the gr2 files. The bone names in the model files didn’t match the ones in the animation files. So Noesis’ Python script didn’t pick up the animation data. The bone names in model files are like “Bip01_L_ForeArm”, but the ones in animation files are like “Bip01 L ForeArm”.

1 Like