Blood, Ice and Steel Act II : adding Fort to the deck crashes the game

:arrow_forward: GAME INFORMATION

  • BUILD #: 100.12.1529.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Upon leveling up, I unlocked Fort along with a few other cards, and when I checked the deck afterwards, it wasn’t in the deck, so I tried to add it and the game crashed. Re-unlocked the cards, tried again, same issue. Re-unlocked the cards, proceeded to the next level without adding Fort, and there it was. Finished the level, checked my deck, Fort had finally been added.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Unlock Fort in Blood, Ice and Steel Act II
  2. Check your deck, and confirm it wasn’t added
  3. Try to add it yourself
  4. Watch as the game crashes
  5. Re-unlock it, then launch a level
  6. Check your deck, and confirm it’s now there

:arrow_forward: EXPECTED RESULT

Upon unlocking a card, it should be added automatically, and adding cards yourself definitely shouldn’t crash the game

:arrow_forward: ACTUAL RESULT

A good amount of the time, cards aren’t added to the deck automatically, and some cards seem to crash the game when manually added

This happened to me too but not with the fort, it was the advanced trading post. Just like you, I unlocked the card and it didn’t appeared in the deck. I clicked on it and crashed.

It’s actually adding any new card right after selecting it as a mission reward and going directly to Deck Builder.

Thanks for reporting this. I also reported it here and someone else reported it as a separate bug report as well (at least 3 bug reports for this issue).

Here’s what it looks like before the crash (with entering the Deck Builder in the same Home City session after selecting a new card):

A workaround is to exit the Home City screen and re-enter it from the campaign menu before trying to select new cards. Crash bugs need to be fixed.