Blue Screen of Death: INVALID_MDL_RANGE

When launching AOE on my computer I am getting a blue screen of death with error code “INVALID_MDL_RANGE”. The first time I downloaded it and launch it the game worked fine, but it hasn’t worked after that, despite reinstalling.

Hi @jerry70450, Which Age game do you have this issue?

Age of empires DE. I was playing around with it now and sometimes it works while other times it doesn’t.

You didn’t ever have these BSOD’s before?

What do you mean before? I downloaded the game and installed it only 2 days ago.

It’s very seldom that installing a game from the MS store causes a BSOD.

Usually BSOD’s are related to faulty hardware or device drivers, this could go from clogged dust in fans, leaking capacitors (if mainboard is very old) and missing device driver updates.

Also there should be hexadecimal code on the BSOD, maybe you can post a screenshot using your smartphone. That would be useful information.

And maybe this link can help you further troubleshooting your issue.

My bad maybe I worded it wrong. It’s not while installing but launching the game after installing. Sometimes it’ll work fine but most of the time I will get a BSOD upon launch. I haven’t been able to find a clear pattern as to when a BSOD will show up and when it won’t.

This is the BSOD screen I see specifically:

No problem Jerry. If it launches and works you can play the game without any other issues or does the BSOD then arrive at some later point in time?

Once it is launched, everything is fine and I can play without any issue.

Thanks for your patience and time to deliver all additional info. They will get those crash dumps if you have telemetry enabled.

Could you also add your system’s specifications (including brand and model if not clone)?

It looks like a system specific outdated device driver issue and or BIOS.

You could run this PowerShell oneliner to check if there are system specific driver updates available that are not installed yet.

Just paste this piece of code into PowerShell and press enter to run it (no result is no updates):
$s = New-Object -ComObject Microsoft.Update.Session; $t = $s.CreateUpdateSearcher(); $t.ServiceID = '7971f918-a847-4430-9279-4a52d1efe18d'; $t.SearchScope = 1; $t.ServerSelection = 3; $c = "IsInstalled=0 and Type='Driver'"; $r = $t.Search($c); $u = $r.Updates; $u | Select Title, IsHidden, DriverModel, DriverVerDate, Driverclass, DriverManufacturer

Please post back the results if updates are found.

I’m actually on a 2017 Macbook Pro 15" with bootcamp running windows, latest updates.
CPU: i7-7820HQ, 2.9GHz
GPU: Radeon Pro 560

Putting the command into the PowerShell gave me nothing so everything should be up to date.

Unfortunately, I was trying to play around and trying to fix this. I uninstalled the game, and wanted to reinstall it but it seems like Xbox insider hub decided to kick me out of the beta, so I can’t install the game anymore. (I’ve reinstalled the game many times, but it has never kicked me out of the beta before).

Hi! I’m having this issue now and I’ve been trying to find info about it all over the internet to no avail. Did you manage to solve it? If yes how?

(Sorry, new to this, made an account just to be able to reply, with all the confinement thing, my friends and I picked up the game and I have been having this issue for a week)