[Bug] AI Will Delete Town Center, All Farms, and Market And Migrate On Team Islands

Game Version:

  • Build (34699)
  • Platform (Steam)


AI attempts to migrate its town on Team Islands (meaning it attempts to colonize opponents’ island). I’ve never seen this before.

Started top middle island. Red eventually migrated to Purple’s island. This seems odd since it’s Team Islands.

Red’s new home:

Red’s old home:

Red’s villagers are all just idle on the new island:

1 Like

Again in another game, this time 4v4 so only two islands. Note that the opponents are still in the game, so the migration attempts get shut down hard.

Yellow moved to other Island.

New Yellow TC:

Old Yellow TC:

Green too:

Old Green TC:

Then Red:

And now they’re complaining that they have no markets, lol

They keep rebuilding their forward Town Centers too

They did it!

I’m having a similar issue. For me, it first occurred on a certain custom scenario of mine. I’ve been working on this scenario ever since DE came out, and never before have I had this issue. This is an 8 players map, and as soon as I start the match (run test), all AI players delete their town centers, markets, and farms (only if the AI doesn’t already have a mill).

For you, did the AI delete their TC, markets, and farms right away or was it mid game?

After some testing, this is what I found:
-It doesn’t just affect Team Islands, it affects any map.
-This 100% has something to do with the “standard” AI, most likely as of the recent patch.
-This bug will only occur when you are allied with more than one player.

My guess is that they tried to add some “fancy” mechanic to DE’s AI, but ended up butchering it. If it’s really bothering you, I would suggest switching to the other AI’s for now.


I just had the same problem on a 3vs3 team islands mega random on hard difficulty.

Two of the enemy AIs and one of my own tried to expand on the their enemie teams island in the late game.
I guess it has something to do with ressource exhaustion, as they started it when wood was getting sparse.
The problem is, that they for one do not properly support the expansion with military and for the other they start to delete their buildings and villagers at home.
I didn’t even attack one AI on his island and he basically destroid halve of its buildings and killed all villagers on his own island, while accomplishing nothing on mine.

One of my own AIs also got kind of stuck with his units in the town center.
While he did initially produce some units he basically did nothing useful the whole game and I had to send him several AI taunts to get him to attack the enemy expansion on our island.

An general AI issue was, that they all kind of sucked at using transport in order to attack with units.
They rarely did it and then only with <10 units.

I just noticed this when playing on Yin and Yang. Hard difficulty for AI, both my ally and an enemy did this.


The issue still persists… on a random map game yesterday (latest game version) I had the same. It was the real world byzantium map. SP 2 v 3 on hard.
At some point the AI deletes their TC’s, farms and markets. Moves all the villagers to the new island and tries to establish an colony. Good idea, but it doesnt make sense to delete your entire farm economy when its save where it is. Let alone the TC and markets… Besides that there was still wood on the island of the main base and no minerals anymore on mine.
Problem is that the AI resignes as soon you kill their last villager on the new island. regardless what the state of the main base is. I cleaned up my island and 2 enemies resigned. One enemy even had still 3 idle vils on the main island and even economy that, if traded at the market could build a new tc, but still resigned… So 2 enemies eventually resigned without destroying their main base. Actually one enemy didnt resign, but ended up keeping all the millitary idle on the main base and just waited to be slaughtered. 2/3 enemies even still had relics in their monastery!
Hopefully this can be patched out because it changed a (for me) challenging game, getting into late game fight, resulting in a easy resign…
I have the replay stored if someone wants to investigate (dont mind the slow mid-game play, though lol)…

Are there any plans to fix this issue? It is still occurring for me.

The Player 2 AI in my custom scenario immediately deletes its Town Center when the game starts. Player 2 is set to Standard AI, testing difficulty is Standard. The map is made by hand and not randomly generated.

i have exactly same, custom scenario and it worked sometime ago perfectly! probably one of the most recent changes created this bug:(

I just created an account for this post, could not even decide what usename I want, but okay. I am experiencing the same issue, but I think I found a workaround, at least as far as the Town Centers go. I had the AI immediately deleting the Town Centers once I started the game, but if you remove the resources from the AI (set it to 0 for all), then they won’t delete their TC’s instantly. I think you can give them resources through triggers to counter the fact that they are without starting resources. Please let me know if this works for you guys as well.

1 Like

Thank you FullTripod8703. It worked!

It fixed my issue but as this is definitely a bug and i know devs are working on i’ll wait for an update.