[Bug(?)]Change Object Range

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 66692
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


After changing the range of any units(melee or ranged), maybe there are ways to set it back to Zero that I could not find yet, there are no simple ways like using change object range(set or subtract) to make it Zero.

The Range is always 0+1 no matter how many subtractions or sets were done after making it larger than 0.

And the effect that 0+1 in melee unit is that it can attack like lancer and kamayuk.

Is there any way to do what is supposed to be done?
Thank you for your time if anyone notices this.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Use the ‘Change Object Range’ effector in Editor and add/set any value greater than 0 on any unit(No matter melee/ranged).
  2. Attempt to use the ‘Change Object Range’ effector and add/set/subtract range back to 0.
  3. As you will see, units’ range will remain 0+1 and that means they will attack like lancer/kamayuk.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
You have to let us change the range of (At least) any melee unit back to 0 which is what melee units are supposed to be.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Reported to the support team and was told to address Community Forums and submit a post on here, and
she is sure other Content Creators & Moderators will be able to assist me in this regard.

Do they actually have range, or is it just a visual thing? If it’s just a visual thing, you probably want to change shown range to 0. You may also want to try using modify attribute instead or as well as what you are using, see if that gets it going.

if you try it/tried it, as you will see/saw, units’ range will remain/remained 0+1 and that means they will attack like lancer/kamayuk.

That is not a LOS problem, it really affects the performance of a unit.

Tried ‘Modify Attribute’ effectors like max range and min range, but it will still remain 0+1.

New Found:
if any ‘Modify Attribute’ effectors are used at the beginning like the ‘Change Object Range’ effector, it will give the same result as the range of units equal to 0+1.

Dear Developers of AOE2DE, it is time to give us an effector which let us change units’ combat mode from melee to ranged as you did to ratha. if you simply turn units’ mode from melee to ranged whenever we edit their range, and the minimum range of ranged units is 1, at least somehow you have to let us be able to change it back to the calculation of the range of melee units where there are no such minimum attack range.

“As If it is too much work that needs to be done, we all know it isn’t. Why? it is already implemented in Ratha!!” This is wrong. After tests, they just simply remove and create between 1740 and 1761 by using the so-called ‘Change Weapon’ button. Dong it.

this most likely isn’t a bug and shouldn’t be filed as such.

what you probably want is shown range, link here:

its how the base game deal with scout’s damage as it ages up to feudal and to castle, rather than the old 3+2 and then later 3+4 for example, it shows 5 and 5+2, thats probably what you’re looking for.

not sure if that can be done via scenario, but datamod is possible.

if scenario doesn’t have it as a feature, file it under discussion or mod section as a feature request instead.

Thanks for the website address but no thanks for your answer.

Please tell me, did you try to reproduce the situation/did you encounter this situation beforehand?

thanks for the reply but no thanks for your comment.

please tell me, did you read what I typed?

Of course, I did, but the problem is did you?

u blamed this situation on the representation of the game coding.

if u ever try the change object range effector yourself, you won’t even blame it on anything like game coding logic or LOS or range shown.

Stop wasting your “precious” time on something you don’t even try to know.

First of all: I have no experience with creating scenarios and using triggers. However, based on your images, I tried some stuff. What seems to work:

Instead of using “change object range” use the effect “modify attribute”. I tested it with two triggers:

1st trigger activates this effect:
Effect: Modify Attribute
Object List: Berserk
Object Attributes: Max Range
Operation: Set
Quantity: 2

2nd trigger activates this effect:
Effect: Modify Attribute
Object List: Berserk
Object Attributes: Max Range
Operation: Set
Quantity: 0

After the first trigger, my berserkers have a range of 2. After the second trigger they have the original range (not 0+1 as in your example).
However, this seems to be applied to all my berserkers. Maybe someone else can tell you how to apply this to individual units if desired.

BTW: The update of the range does not seem to effect currently attacking units. After the 1st trigger I commanded a berserker to attack a building. The berserker did so according to his attack range of 2. However, as the 2nd trigger got activated and his range was reduced to 0, he was still attacking the building with the same distance to it. Only after another attack-command he had to move towards the building so it was within his new attack range.

1 Like

That’s what we need instead of someone randomly ramming around without good targets. Thanks.

I did try the modify attribute effector and it works well, and this is a prove of the change object range is bugged.
What is a bug? When we encounter something we are not expected.
In this situation, although the change object XXX set effectors are left for many old-school maps which are not updated and still using them, we should still call it a bug. You let us change objects’ range from 0, it is expected to be changed back to 0. At most, you developers can say “This is only for old-school maps we are not gonna update it and we already give you the modifying set, deal with it.”
It’s fine but a bug is still a bug, and I am here just to report it

With Change Object Range, It seems like whenever it is used, the engine turns the calculation method of range of those affected units from ‘melee’ to ‘ranged’, How? We knew there is a minimum range, 1, for any ranged units as the engine needs at least 1 tile to let the projectile be fired or something like that.

Thanks for experimenting the change will not apply itself until we manually ticked the engine to update the effect of change. Who knows if it is related to animation state coding?

Yes, this is gonna a problem too, luckily not for me this time. The amount of affected is not important in this scene.

Maybe this conversation is also interesting for you: Change Object VS Modify Attribute - Age of Kings Heaven Forums

Assuming that it is true what they say, then this holds:

  • Modify Attribute (HP, Armor, range, etc.) changes the stats for the entire unit type in the game’s database.

  • Change Object (HP, Armor, range, etc.) changes the stats for units on the map.

  • Modify Attribute will affect all unit of a particular unit type that the player has created and will create.

  • When we use the effect Change Object ___ (such as change HP, armor, attack, name), it makes the unit no longer a part of the game’s database, so it is no longer changeable by the effect Modify Attribute.

  • You can use the effect "Replace Object " to return units back to their the default state.

1 Like