BUG: CTD when reaching castle age, in 40% of matches

What information led to the fix?
I get they aren’t 100% sure, but they did find something to change, perhaps we can be more specific if we know what to rule out.
The reproduction steps are pretty vague by nature: Play, Castle, Crash.

I’m guessing we’ve ruled out if it’s civilization related.
Is it only affecting specific video cards, NIC’s or other hardware?
What might be most helpful for them to reproduce?
Perhaps a screenshot that includes list of player names and/or civs?
Perhaps a screenshot that includes player scores and the game timer?
Screenshots of task manager during crash?
Video of crash?
Just dxdiag files?
I think everyones event viewer says the same error if you run the game from exe instead of steam.
Replay or recorded game files of crashed games? I hear they crash the game again when watched lol.
Some of these cannot be done at the same time after a crash.

1 Like

Three times now I have crashed seconds after hitting the imperial age in ranked games. This has only been happening the last few days.

1 Like

Had 3 game crashes in the past 2 days playing ranked matches. All of them came as soon as I hit the Imperial Age. Anyone else having this problem the past few days? Or is it me? I think it’s about time for another update IMO game still feels like an unfinished product. And you still got lag fests in the 3vs3 game modes and I won’t even try 4vs4.

Just came here after it happened again, half of my games are either this or disconnect :frowning:

Continuing the discussion from BUG: CTD when reaching castle age, in 40% of matches:

AOE Fix your ■■■■ bugs all over this game just happend to me after it happening to a mate 2020 i thought frustrating and a massive waste of ■■■■■■■ time

here is something specific don’t release a game if it has more bugs then the amazon in it dc from games left right and center makes me wonder do you guys know what you are even doing? fix this game or you will loose people through frustration sincerely EVERYONE

Thus far, I’ve only played single player campaigns. I haven’t gotten past the 2nd Sundjata mission. About 12-15 minutes into the game it’ll crash to desktop with no errors in Event Viewer. Regardless of whether I’m in the Castle Age or not. Each time my actions have been different but I don’t get far into the game, usually around that 12-15 minute mark. Game will crash even after a reload, usually about 2-3 minutes into the latest save game or auto save (I can even save a game just moments before the crash and it will CTD around the same point).

I have the game from Steam.

Here’s troubleshooting I’ve tried:

  • Tried low graphics, ultra, high, etc.
  • Tried different resolutions
  • Disconnected my 2nd monitor
  • Uninstalled & Reinstalled the game
  • Disabled the UHD DLC (both with the ingame checkbox AND unticking the DLC from Steam)
  • Increased my virtual memory to 20GB
  • Updated my graphics card driver
  • Windows 10 Pro, fully up to date
  • Windows Defender, whitelisted the AOE2 folder
  • Totally disabled Windows Defender
  • Tried running the EXE directly
  • Tried running the EXE in compatibility mode for Windows 7
  • Tried running the EXE as Admin
  • Tried Program DPI settings, High DPI scaling override (all three options)
  • Updated Visual C++ to the latest I could download from MS.
  • Moved the game from my HDD to my SSD.

I’ve attached a zip file of all the logs, my save games, a video capture of my last attempt to play, replays from the game, & the aoe2_de_s mini dump file. Here’s my OneDrive link.

  • Do you experience crashes at any other time, or is it only when leveling up to the Castle Age?

I experience other kinds of crashes at times for example the game will randomly freeze and “stopped responding” and then close down but with this particular crash it shuts down and the program disappears the moment I hit castle age.

  • Does it matter whether you’re playing in a Multiplayer Match or a Standard Match against AI? Does the game mode change your experience at all?

I’ve only experienced it during multiplayer games, happens with several different game modes

  • What CIVILIZATION(S) are you playing when you experience the crash? Do you experience the same crash when you choose a different civilization?

I do not believe the civ matters, i’ve experienced this exact crash while playing as the cumans, britons, celts, bulgarians, vikings, huns, mongols, chinese, franks and goths.

  • Are there any error logs in any of these locations regarding the crash?
    • C:\Users\AppData\Local\age2_x1\logs
    • …\Users\UserName\Games\Age of Empires 2 DE\logs
    • In the Windows Event Viewer

I checked my logs and every time it crashes the log files are completely blank. When I play and it doesn’t crash it has a full log.

  • Please include a link to your dxdiag for hardware information, if possible.

Im running it on a i7 7700k not oc, GTX 1080 FE, 16gb of ddr4 3200mhz ram and its installed on my m.2 samsung 970 evo ssd.

  • Do you still experience the crash if you disable any of your content mods?

i have no mods enabled. completely stock game.

i’d just like to add this has happened to me just the once, dead on hitting castle age in black forest at approx 17 minutes.
That was a few weeks ago in a 3v3 online game. I’ve played a lot since then it’s not crashed in game since. Although likely a coincidence, that was the only time I’ve levelled up at 17 minutes, usually 18-20 minutes.

Hi everyone! Today’s hotfix should come with a fix to the crash when advancing to a new Age. I’m going to un-pin this thread, though please let us know if you continue to encounter this particular problem.

For context:

Thanks again for your reports and for keeping us informed!


First game I played after the update loaded, hit castle age and within 15 seconds (I managed to place a TC) the game crashed.

1 Like

This was a ranked gold rush map. I was random and had the monk/elephant civ. (Burmeese? with the mounted dart throwers?) Just CTD right when it was getting good.

Just tested with 1 game and it still crashed when I’ve completed the Castle Age research in multiplayer.

CTD happened to me last night for the first time in a while. (pretty sure it was immediately when hitting Castle Age. I know I was on the way up but can’t remember if I heard the notice or not that I hit. My opponent was already in castle. Lost my elo too…

@GenMax, @JelvNL, @PromptedPenny75 Thank you all for staying on top of this! Would you mind passing me a copy of your dxdiag.txt and any error messaging surrounding the crash? You will likely find said messages in one of three places:

  • C:\Users<WINDOWS USERNAME>\AppData\Local\age2_x1\logs
  • …\Users\UserName\Games\Age of Empires 2 DE\logs
  • In the Windows Event Viewer

I will get this information passed along to the team so they can continue digging into the issue!

Hello @ everyone in this thread! If you are STILL encountering a Castle Age crash reliably, I’ve been asked to one thing that will help the team:

  • A recording of the crash if you have one. I know this is not always possible, but if you happen to catch it on OBS, please send us a link.

Whether you have a YouTube link or a stream VOD, send it my way and I’ll make sure it gets to the team!

Thanks for bearing with us!

Game Version:

  • Build 34223
  • Platform Steam


CTD approx 5 min into Imperial Age. The game crashed to desktop, the game was Ranked Team Islands 1v1, I was Franks vs Malians, and it crashed when I was controlling some Galleons and Cannon Galleons and bum.

Windows Event Viewer log:
Faulting application name: AoE2DE_s.exe, version: 101.101.34223.0, time stamp: 0x5dfb2884
Faulting module name: ucrtbase.dll, version: 10.0.19541.1000, time stamp: 0x5268267a
Exception code: 0xc0000409
Fault offset: 0x0000000000072eae
Faulting process ID: 0x488
Faulting application start time: 0x01d5c957c8a3bdfe
Faulting application path: E:\SteamLibrary\steamapps\common\AoE2DE\AoE2DE_s.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report ID: 9b0af870-2a9a-4120-8327-2fe70ed6de86
Faulting package full name:
Faulting package-relative application ID:

AoEII DE log:
No log found for this session

DxDiag.txt (79.9 KB)

1 Like

Happened to me again after the hotfix.

Khmer, Blackforest 1v1. Just upped to castle age, froze and crash to desktop.

Error 1/16/2020 1:52:04 PM Application Error 1000 (100)Log Name: Application
Source: Application Error
Date: 1/16/2020 1:52:04 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Faulting application name: AoE2DE_s.exe, version: 101.101.34397.0, time stamp: 0x5e1403cc
Faulting module name: AoE2DE_s.exe, version: 101.101.34397.0, time stamp: 0x5e1403cc
Exception code: 0xc000041d
Fault offset: 0x00000000002d6cb6
Faulting process id: 0x7130
Faulting application start time: 0x01d5cc745c91bf55
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\AoE2DE_s.exe
Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\AoE2DE_s.exe
Report Id: c2349cf4-c30c-41b3-b813-af532be0250c
Faulting package full name:
Faulting package-relative application ID:
Event Xml:



C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\AoE2DE_s.exe
C:\Program Files (x86)\Steam\steamapps\common\AoE2DE\AoE2DE_s.exe

Is there anything else from the logs that would help fix it?