BUG: Furor Teutonicus Achievement not Awarded at Completion

The achievement ‘Furor Teutonicus’ does not get awarded after “Defeat all opponents instead of collecting the required Relics in the first Barbarossa mission “Holy Roman Emperor”.” I have tried it multiple times via save points etc but it still doesn’t award it

Check out https://www.trueachievements.com/a288082/furor-teutonicus-achievement?showguides=1 and that site in general for such things :slight_smile:

Don’t hire the Cuman force in the scenario and you should get the achievement. It must be set that you can’t complete any of the actual objectives. Kind of lazy, as is the fact that when you win by defeating everyone, it still gives narration about having captured the relics.

1 Like

I’ve attempted this twice now, I can confirm that hiring the Cumans, and declaring war and killing them voids the achievement.
I really don’t have it in me to play again and just straight up ignore the Cumans, but I hear that does the trick, it certainly looks like a bug to me.

Edit: just went back, just don’t change your stance on allying with cumans, don’t hire them, don’t attack them. And don’t touch any relics, and you are good.

Didn’t interact with Cumans (still discovered them), got the achievement just now.

Yeah it was the Cumans. Sadly I wasted another 2 hours to get the Achievement