[Bug][LAN] Unable to join Local Area Network lobby when **cross-platform**

Game Version:

  • Build (4597979)
  • Platform - BOTH


Windows Store version is unable to join LAN lobby when a Steam version creates it and vice versa.

Reproduction Steps:

  1. Steam Version - host a LAN lobby on same network.
  2. Windows Version - see lobby in multiplayer listings
  3. Windows Version - attempt to join steam LAN lobby
  4. Windows Version - lobby attempt failed.

Note - using the same network and same PCs, two steam accounts are able to join the lobby. Haven’t tested it with two Windows Store version since I don’t have two Window Store versions.

Having the same issue.
Game on version 101.101.37906.0.0
Platform Both Steam and Windows 10(both versions have the latest release at the time of reply.)
I have siblings that I play the game with.
2 on Steam and I am on the Microsoft Store version.
While we all can play multiplayer on a server. However, the Use Lan Network fails when connecting to the Microsoft Store version and vice versa

The Steam version is on Windows 10 (1909) and the Microsoft Store version is on Windows 10 (2004)

Keep in mind that I have already allowed the Game to pass through the firewall and all three computers can ping each other. I have even tried another Router. Cross-play is enabled on all PCS

Both Steam version can connect once the game is searched for in the Lobby Browser both ways. PC1 connects to PC2 and vice versa. The game won’t pop-up if the Lan filter is set. but when the filter is cleared, the Steam Versions can find one another and join successfully. I didn’t test furthure to see if performance was good though. The Ping says 0MS so I assume that it is good.

The Microsoft Store version seems to cause problems.
If a loby is created in the Microsoft Store version changed the name, using local network as the server option and set to public and the rest is still at default.
The Steam Version can see the Microsoft Store game but cannot join. After 3-5 seconds, the message is unable to join the game.

If the Steam version hosts the game, after renaming the game, setting the server to use lan network, and having it set to public. The Microsoft Store version cannot see the game if I searched for the name.
However, If i send an invite via the Steam version, the game pops up on the Microsoft Store Version’s loby after a search.
If I try to join the game it says the same message but on the next line it says unknown error.
I tried to send an invite from the other Steam version and it ends up with the same conclusion.

Both game versions do not see each other’s game if a filter is set to Lan