[BUG] Photon Man not working anymore?

I got the 21st Century Man achievement long ago and unlocked Photon Man for permanent usage, but with the patch that came out today (Build 36906), I don’t seem to be able to do it anymore? I tried typing, “Photon Man”, “photon man”, “photonman”, and “PHOTON MAN”, but nothing gets created. I’ve always been able to type “photon man”, no problem. I was able to make a couple “how do you turn this on” cars on the Hill Fort map I was playing; but not photon men.

Anyone else having the same issue?

1 Like

The cheat is “E=MC2”.

Did that change? I could’ve swore it used to be “photon man”? Even a quick Google search says this:

  • photon man - Create a guy in a white suit with a quick- fire laser gun
  • e=mc2 trooper - Creates a guy in a white suit with a slow- firing nuke gun

Actually, neither “e=mc2” nor “e=mc2 trooper” do anything for me. I just get the annoying doorbell sound (that we can’t disable :unamused:) as if I’m chatting. (Should I have e=mc2, too, I wonder? I’ve completed all the challenges they’ve done.)

The “photon man” cheat code, on the other hand, doesn’t give me a doorbell sound; which tells me it’s at least ‘trying’ to work, but it isn’t actually since no photon men generate.

I just tried “rock on”, too, and that worked just fine.

Back to cobra cars I guess


2 2 2 2 2 2

I also don’t have photon man anymore after unlocking it during the AoE I event…

1 Like

It worked for me today. I will keep an eye on and see if it consistently works for me in future days. I’m thinking it was just some temporary glitch; possibly wrought from a few things not launching until today (i.e., the Medieval Tech event), even though the patch installed last night. (I also wasn’t seeing the Medieval Tech Event yesterday, but I am today.)

Still not working for you? Maybe try tomorrow in one last ditch effort

Good News. I also got it to work again.

1 Like