[Bug Report] - Tampering Detected

I’m having a problem with my AofE2 DE since the September Update,

Game version no 101.101.40874.0 5548497.

Since the update a month ago occasionally when playing online, campaign or Barbossa brawl I will be kicked and given the attached “tampering detected” message. To be clear I don’t use any kind of tampering or other software, and I’ve never had an issue till the update a month ago. I also don’t have any issues while playing Dota 2 which has similar anti-cheat software.

How I’ve tried to fix it

  • I’ve tried the other solutions in other posts from earlier in the year including verifying integrity of game cache, uninstalling and reinstalling the game.
  • I use Kaspersky Antivirus and have tried turning off protection, and turning off both scans and rootkits scans while I play.
  • Updated all drivers.
  • These all work for a time, but then I will be kicked again a day or so later while playing.

Any help would be really appreciated.


Super frustrating. Having the same issue even after I turn off both tamper protection and real-time protection on windows 10. Made sure that aoe2 de was an allowed app through firewall, yet it drops. It even drops when playing campaign mode. Steam shows 100% complete when I validate files. Reinstalling does nothing to correct issue. Honestly, it’s a huge turnoff and makes me want to go back to forgetting about this game for a few more years before trying to play again.

I have the same issue. Looking forward to seeing potential fixes…

If I launch the game outside of steam it helps for 2-3 games and then starts dropping again with same error message.

a friend said unsubscribe to all mods, including official ones solved the problem.

Can we get a confirmation from the Devs that this is being looked at? It seems to be largely ignored and is affecting a lot of people, with reports on here and on Reddit. I’ve had around two thirds of my games crash which is insanely frustrating, as I just want to be able to play the game. I’ve tried every solution suggested online and nothing works, even completely disabling my firewall.

My theory is that it is related to the change in last month’s update “Implemented additional safeguards to defend against unsanctioned cheating”. I never had this problem before that update.

Thanks for your work Devs, I hope to be playing the game reliably again soon.

1 Like

can u try unsub every mod and have a clean game, or simply do a reinstall to see if that helps. i know it sucks but tr ythat first

Thanks for responding, yep I’ve tried unsubbing from every mod, even small trees. Have also deleted and reinstalled on Steam to no avail. It sometimes works a few times in a row with no problem then crashes again

1 Like

Did anyone find a solution for this?

I am also getting this error still in the campaigns. Sometimes I get kicked from games after as little as 20 minutes.

Hi guys!

Sorry for the delay. We are now tracking this issue :star:

Any word on status? This has been happening to me on and off for about a week now. Dropped four games in a row last sunday/monday, I disabled my antivirus entirely and it worked for a few days. Now today it has started happening again even with the AV turned off. Super frustrating losing elo to crashes