[Bug] Sforza Mission 2 Sea Gate Cannot Pass Through

Game Version:

  • Build (33164)
  • Platform (Steam)


Cannot move through this unlocked Sea Gate with sea units. Probably just a pathing issue.

Reproduction Steps:

Click on the other side of the gate like a mad man.

1 Like

Click the gate and press ‘delete’ key :wink:

Game Version:

Version 101.101.39515.0 0
Installed through Windows Store


First, sorry for necro, but my issue is at least mighty similar

Cannot path transports that have Unloaded a unit out through the closed sea gate. Affected transport can get back into the harbor by nudging the exposed gate end at just the right angle and easing around the corner. Affected transport can also path through if the gate is held open for it.

Reproduction Steps:

Images to follow along with here: https://imgur.com/a/muUvoKW

  1. Have a unit board a transport, either the starting transport or one created at the dock. Boarding can be done by right-clicking to board, garrisoning, or by setting a building/tower gather point to the transport.

  2. Send the ship through the gate and back.

  3. Move the transport near shore and click the loaded unit to drop it off. Leave the gate and come back.

  4. Load your unit again, then use Unload to drop it off. Try to leave the gate.

  5. Hold the gate open with a different unit, transport or otherwise, and path the affected transport through.

  6. With a new transport, repeat the step 1. Leave the harbor and drop the unit off. Try to path back through in a path perpendicular to the gate.

  7. Move the transport around to the left end of the gate and touch that end. See the picture for the correct angle. It helps to come at it from directly left and right click a couple times on the tile hidden behind the left pillar of the gate

  8. Without losing contact with the gate, ease the transport around and back in. The trick seems to be to keep right-clicking along the curve the transport needs to follow around the pillar, just a tile or two in front of the bow of the ship.

What’s Weirder:

I believe there were a couple times when something reset whatever the problem was. The time I noticed soon enough was just after luring Pesaro’s War Galley down to the first tower with a fire ship. The fire ship and one transport took damage, but I had two affected transports, and both reset. I’ve tried to reproduce the reset, but no luck.

I’ve also tried reproducing the Issue in the Scenario Editor, but could not seem to get the same issue with gates in any orientation.