[BUG] Stuck in civilization overview when picking one. Force exit AOE2 DE

I’m also getting this issue when I get invited through steam.

1 Like

We tested a pretty consistent repro case.

  1. Friend sends invite through Steam while the game is not running.
  2. Click on “Play Game” and advance to the game’s lobby.
  3. Open the civ-select menu and experience the soft lock.

For fun, we tried it again w/ other set ups and found it pretty much ONLY happens if you accept the invite before launching the game. To get past the soft lock, make sure you enter the game’s main menu prior to accepting the Steam invite. Then it works just fine.

1 Like

not the case for us. we tested with steam invite when player already in game, it still locks them. i think its just steam invite in general but didnt bother to test other.

A friend of mine encountered the same issue four days ago. I’ll try to tell you everything I know in case it helps to pinpoint the issue.

I invited him to my private lobby (just me and him and later 2 AIs) over Steam and as soon as he opened the civ selection view his game froze. I still had a civ selected from earlier games and did not make any changes before he joined. He is not too much of a tech nerd, so I’d be difficult to get a video. We tried this same setup several times and the result stayed the same. As far as I can remember we did most of the troubleshooting steps when he bought the game as it would not start. The issue was that Visual C++ was missing. I tried to diagnose the issue over voice chat, but all relevant additional information that I have is that he is using Windows 10 on a Laptop with an integrated Intel graphics card which apparently is the same machine that we played on >10 times a few months ago without any issues. The drivers are provided by Windows 10, I didn’t make him update them manually.

I was playing on Ubuntu at that time and I noticed that the framerate tanked from 60 into single digits as soon as I hovered the mouse over one of the UI components in the civ selection overview. When I moved the mouse quickly through the screen the button hover effects of the civ buttons played with quite a bit of delay one after the other. It looked a bit like some observers on the buttons took too long to complete and the events clogged the event queue up. At least with Swing or JavaFX this would have been the issue. I was running the game on a Ryzen 9 and RX480, so I wouldn’t be surprised if my friends game was not frozen but just taking forever (>15 seconds) handling the events before he shut the game down.

After this I switched to Windows 10, there were no more issues for me and he played random civs, but we still weren’t able to play because the game kept speeding up and slowing down for him. It’s very plausible that this was due to unreliable connectivity on his part (we measured it and the latency of his pings varied a lot and over a wide range), but I had the same problems under Linux and my connection was fine.

If there is any additional information that I can provide just let me know.

Encountered this bug today. The game was not already launched. I clicked on the dropdown menu on my friend in steam friends list and selected “Join Game”. When I tried to select civilization, no buttons responded to mouse clicks. Mouse overs worked, game was not frozen, but no response to clicks. Had to alt-f4.

I was able to resolve the issue by joining the lobby after the game was already launched.

The game did not have any mods.

I am facing the same issue. I am forced to play random civ because otherwise I am stuck there in the civ selection menu and need to restart the game or ask my friend to cancel the lobby and create a new one.

Build 101.101.43210.0 5867313

Lobby had 3 players and 3 AI (any number works, not related to bug)

Repro video: (URL hidden)

Summary

https://aoe2bug.s3-us-west-2.amazonaws.com/2020-12-21+20-18-07.mkv

Repro steps:

  1. Friend sends invite to multiplayer game via Steam while the game is not running. (only repros on Steam, not Xbox Live)
  2. Click on “Play Game” and advance to the game’s lobby.
  3. Open the civ-select menu and experience the soft lock.
    Actual: The game does not crash or freeze. It simply stops accepting clicks. CAN mouse over a race. CAN NOT select a race, CAN NOT click confirm, CAN NOT click cancel, CAN NOT click X. The only way to exit is Ctrl-F4.
    Expected: Able to click to select a race, click confirm, click cancel, click X.

Repros 100% of the time. I’ve owned the game for a year or so. This used to work fine until one of the recent builds in the last few months.

5 Likes

they just had to change the civ picking UI to make it look fancy. always form over function nowadays its sad.

I just had this problem 4 times in the same night. can confirm

One of my mates can reliably reproduce this. It just happened to me aswell. One thing we noticed is that it does not appear to happen to the host of the lobby.

I believe if you “start” the program (the actual .exe) through steam invite, then civ menu remains bugged no matter what and requires a restart of the exe.

once restarted, would need to manually join or through the invites inside the game.

I purchased AOE2:DE yesterday through Steam. I have the same problem: it is impossible to exit the select civilization screen. The cancel, confirm, and X buttons do nothing. The civilization buttons recognize that I am hovering over them with my mouse, but I cannot select one. Only way to exit is to Alt-tab and kill the exe.

Steps to reproduce the problem:

  1. A friend with AOE2:DE invites me to play through Steam chat
  2. I accept the invite and am taken to the lobby
  3. I click on the ‘Random’ civilization button to change it
  4. From that point onwards it’s impossible to return to the lobby, or do anything else with the game

I have tried playing with a random civilization and the game worked, for a while. Playing against three AIs with my friend, my game spontaneously exited about 30 minutes into the game. I have been playing AOE2 for many years and have never had that happen.

Win10, Lenovo laptop ~2 years old.

1 Like

Welcome to AOE where the devs and co break the game constantly enjoy!
(btw it isn’t your PC they have broken the game month’s ago so many people are having issues)

Yea we have this all the time, I haven’t found a consistent way to reproduce it but in ranked I just let the countdown happen and I’ll still be able to join the game. I don’t care much for the new civ picker, I rather have the old button back that didn’t freeze the game…

What do we as end users have to do so we can use the most basic functionality of a game that has basically been working for 22 years now?
Don’t you think that its shameful that such a basic feature is still not fixed, after two years of the definitve editions release date?
Please explain the challenge behind a drop down menu and a select.

For me happens every single time, weirdly only to my friends I can always choose civ no matter what, we decided that they create the lobby themselves and then invite me that’s the only way we managed to play, which is crap but anyways, I noticed that clicking under the cta also works, for me seems that with this awful new interface the hit area is displaced.

As I said, before, I’m experiencing this issue when friends invite me through steam.
Reproduction steps:

  • Make sure Age Of Empires 2 DE is Closed, and have Steam Running.
  • Friend “A” Create a multiplayer ranked lobby.
  • Fiend “A” invites you through Steam message ( “Invite to Party” on lobby -> “Steam Invite” on invite to party menu -> “Invite” on friend selection )
  • Accept Invitation ( this starts AoE 2 DE and goes directly to the lobby )
  • Friend “A” starts to look for match ( not sure if this is necesary or not to reproduction )
  • Open civ selection Menu, Now you are stuck in selection window.

Build: 101.101.43210.0 5867313

so far I’ve noticed this happends every time on a 4v4 ranked lobbies ( this is what I mostly play, But i’m sure this happends on 2v2 and 3v3 too). the way I “dodge” this bug is openning the game , wait until the game has reached to the main screen, and clossing the “news” windows before I accept the invitation to the ranked lobby.

hope it helps

2 Likes

I’m experiencing the same thing. It’s when a friend invited me to play a game and I wasn’t the party leader.