[BUG] Stuck in civilization overview when picking one. Force exit AOE2 DE

:arrow_forward: GAME INFORMATION

  • BUILD #: 42848.0 5818516
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

In multiplayer, a player joining another one (so not the host) and picking a civilization might get stuck on the civilization screen.
On 3 games, every time a player wanted to pick a civ at least one f the; had to force the game using alt F4 and restart it. When joining again, the same issue persisted forcing players to use a random civ.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 50% of the time / matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Join a multiplayer lobby
  2. Click to pick a civilization
  3. Picking does not work, only able to exit the game using alt+f4

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

15 Likes

Can confirm on this one. I’ve been stuck in the Civ Select menu multiple times.

3 Likes

I’ve had two players have this issue trying to join a custom match. Both joined through Steam invite.

2 Likes

Question: Does this issue only appear when attempting to play a game that employs user-generated content such as a mod or custom map? It looks like we are tracking similar symptoms when the UGC warning normally pops up, which also explains why the host would never see this problem.

Let me know if this is the case and I will update our ticket! Thanks for the report!

Hi

It was with a random map, no special maps, mods or custom maps were used/selected.

1 Like

its both. maybe an UI issue not sure, happens to us using mods and also base game without mods.

civ choosing menu wont let us get out of menu, clicking confirm or cancel does nothing, press escape key does nothing and forced to restart the game.

2 Likes

No, I’ve had this issue show up while picking civs for a ranked match.

It looks like we have a fix for this in the works! Thank you all for the report; watch for that fix in an upcoming build and let us know if it continues to be an issue afterwards!

4 Likes

Hi,

I can confirm this issue still exists after the latest NOV 24 hotfix, I have experienced 2 incidents today after the update. Is anyone else still getting stuck?

EDIT: just to add, this was not a UGC game, just a standard online lobby

2 Likes

yep, two of my usual play mate getting the same issue after hotfix. its not yet resolved.

Well the UGC warning bug was pretty much different. You still got the warning, and could click it, but AFTER handling that message you got stuck (I assume you were not returned to the screen you should be returned to…). Here no messages pop up? Really sounds like you guys were not able to reproduce the UGC warning bug at all, but still somehow fixed it?

Got two players I normally play with still experiencing the issue following the hotfix.

can this be fixed already? seemingly annoying for people to have to restart the game and rejoin only to be stuck again and forced to random. @GMEvangelos possible to get another hotfix for this? 11

1 Like

Just want to let you know that this is definitely still an issue. I’ve seen it mentioned somewhere that appears to be more frequent when players are added to a ranked party through Steam invites. I’ve noticed the same. I was stuck in the menu 3 times yesterday myself and a fellow player stuck at least twice.

I also had one player stuck in the civ selection menu in a custom game.

1 Like

Still an issue over here as well. Using steam invite, only the host can choose its civ. Other players are forced to use random.

1 Like

I’ve reproduce this bug consistently when a friend invites me through steam and I dont have AoE running already. If I’m already in the game main screen when i accept the invite, this bug does not occur.

3 Likes

Hello everyone! It looks like many of you are reporting that you are still experiencing a freeze or drop on the civilization menu. If this is the case, I will need more specific information about the issue, including:

  • A video (if possible).
  • Confirmation of the build number where you’re experiencing the issue.
  • Details of the lobby: how many players, what civilizations selected, etc.
  • How often it affects your matches.
  • Confirmation that you’ve worked through these troubleshooting steps (and that the issue still occurs): The game crashes shortly after it launches or when trying to start a game
  • ANY other information to help narrow down and define the problem!

I appreciate everyone weighing in, and hope to hear more from those of you still experiencing this issue in the current build!

1 Like

Hi,
This problem has indeed occurred the last month or so and what AlleN6415 says seems to be on the money. The host never has the issue. It is the people that get invited through Steam (not in-game invite) that have the issue.
1 of my friends have had this issue each time the last few games we tried. The other has it every so often.
I now invite them in-game and the issue doesn’t present itself. They also need to start the AOE game up themselves and not be in a game that has been started by a steam invite.

My friends describe the issue as follows: In the CIV selection screen they can’t choose a civ and it hangs and can’t click confirm or cancel. They need to fully exit the game (by killing the windows process) or reset the computer to get out of it. They however can play the game if they keep the civ on “random”.

My one friend who has had the issue each time has reinstalled the game with no avail. Our games are 3v3 (we 3 vs 3 AI)

2 Likes

Happened several times today when trying to play some games with a friend. Almost every time he brought up the civ picking screen it’d lockup and he’d need to force quit the game. Both running the latest patch of DE 101.101.43210.0 5867313. Just a normal private compstomp game. Nothing fancy. For sure seems as though it’s related to the new UI.

actually, many of my friends were already in game when I extended the invite through steam and they are still getting stuck in civ menu.