Buildings & Units Turn Invisible + Unselectable

Game Version:

  • Build (Launch & 11/17 Steam Versions)
  • Platform (Steam)

Issue:

While playing a multiplayer match with friend, multiple buildings and units became invisible (both mine and the matching type for other players), which also made them unselectable, either by clicking where they were or box selecting. My other units and AI units could still interact with them but I couldn’t.

I was playing Vikings as P1 on a Team Islands map in a lobby I started.

When I reached Feudal age my mill dissapeared, my vills were still farming and walking to it but I couldn’t click on it or hotkey to it, I built a second one and there was no visible blueprint but when placed it would show the construction animation etc.

After this multiple other units and buildings started dissapearing, including stable, beserker, monk etc.

The only odd one was Galleons, where the sails were visible so I could still select and move them.

Reproduction Steps:

  1. Start game (Empire Wars, Team Islands, Dark Age Start) as Vikings
  2. Advance to Fuedal
  3. Observe multiple buildings and units being invisible.

I didn’t think to take a screenshot but I will see what the replay looks like.

2 Likes

My partner is having the same problem.
I dunno why @PCS70 you think its an MS account problem?

1 Like

Hi Abedecain, welcome here.

I meant not necessary a problem with the MS account itself but more a problem with the cached local MS account connected user profile. The easiest way to find out if it’s related to the user’s profile folder is to test things below a fresh preferable local non MS connected account with administrative permissions.

Well that was a mouth full.

1 Like

Just did this, same problems. To your thoughts on the other post, it is idential to this person and everyone else whos having the exact same problems, both on this forum:


and on steam:
https://steamcommunity.com/app/813780/discussions/search/?q=invisible&gidforum=1639802081896908067
The commonalities are, steam version; THe stable, mill, 3rd era and above, the scout unit and monks along others are missing; these units are unselectable, some apear in battles, leading to a probable texture issue; People with these errors also have frequent crashes, seemingly related to missing modeles/textures.

1 Like

Hey!

I recorded the same bug:

I hope it is useful.

Also, in the same game, I had a bug where the villgers unit menu icons (commands, buildings, repair etc…) went missing for a short time.

Is this related, or should I make a new bug report?

thanks

1 Like

Hello ,
I am having the same problem with invisible units and buildings.
Most of the time it is the Stables and the Knight being invisible.
I also have the same random crashes to Desktop

1 Like

I have seen the same issue twice. As it happens I was also on Vikings but I doubt that would be the only civilization to see it. Steam version. I was playing fine through multiple ages and towards the end game I saw invisible units and I could only see a part of if they had a damage bar. It seemed mostly geared toward other opponents units. Nobody else on the game (2 others) saw what I saw. Other people have the nice videos and I didn’t capture any.
Since I know programming I associated this as graphical resource exhaustion due to number of units and memory usage.

This issue could also very well be GPU related.

My GPU is NVidia GTX 760M and I play without UHD enabled (it got no use on 1080p 24" monitor). It’s a good plan to post your dxdiag.txt log files here.

Or just wait a while because this month a new build will come which should address a lot of reported issues.

Hi same prob here, appeared after the patch… Anyone knows about solution?

Game Version:

  • Build (101.101.34223.0 0)
  • Platform (Microsoft Store)

Issue:

Units disappear randomly. Once they disappear, they are unselectable and undraggable. The only way I was able to screenshot or know they disappeared was preselecting them before they disappear to show the HP bar when they do disappear.
This also happens to military units too.

Reproduction Steps:

Play with multiplayer, Byzantines, Black Forest, Normal Map size, etc.

Screenshot:

See highlighted villagers on left side, and note one sprite is missing.

2 Likes

Same here. I have the game installed on 2 PCs and running in 2 different accounts (my wife plays multiplayer with me vs AI). Happens every random map game in both PCs. Villagers and scout affected since the very beginning of the game, but villagers apparently only when collecting resources. I can select the scout pressing the “,” shortcut if he is idle or ctrl+1,2 or whatever control group assigned, otherwise if he is “invisible” he is not selectable.

Hello there. I solved the issue by:

  • Searching Age of Empires 2 DE in the Microsoft Store
  • Finding the Enhanced Graphics Pack DLC
  • Updating the Enhanced Graphics Pack manually.

For some reason the Microsoft store don`t updates it automatically after the 34223 update.

Before these steps I was experiencing:

  • Tiny villagers harvesting sheep
  • Some Invisible and unselectable villagers when harvesting anything. They could disappear with no apparent reason and return later
  • Scout can disappear and become unselectable too.

After doing the update none of the issues showed up so far.

2 Likes