Can not play a Random Map, Game crashes

Hello There.

I am a new member, and came here out of desperation.

I recently bought the extended version on Steam, having played the original waaaaaay back just after it was released.
I have finished the campaign and watched the tutorials for the Athenians and the Chinese, but whenever I try to play a random map, the game loads the bar fully, then quits the game and returns to my desktop.

I am playing on a Windows 10 home laptop, Strong enough to handle graphics that is more demanding.
Has anyone else had this problem and managed to solve it.

Thank you for any help

Delta!

Do you have the latest public patch 2.7 version installed?

If not please enable it by right clicking Age of Mythology in your Steam game library, choose properties and then go to beta tab and select patch-2.7-public-beta- in the drop-down list.

After that the game will update to latest version.

Please as precautionary measure to overcome any permission related problems make sure you launch the Steam client as administrator before changing the setting on the beta tab and running the game after downloading the updates.

And welcome here of course. :slight_smile:

Thank you for the welcome. I do have the expansion. after you posted I have removed the game and downloaded again, and the update was also downloaded.
I am going to be honest and say that I think that Steam is run as administrator… But I do not know if I have done all of that right…
I did try and play again, and it does the same thing…

You can run Steam as administrator by closing it first and then right click the Steam client shortcut and choose ‘run as administrator’.

Actually it should not matter but it does with certain software installations. Also this should be handled by the Steam or software package itself in those cases, but sometimes it doesn’t or people just say no (to the UAC make changes to your system question).

I think the 2.7 patch works more like a mod, so I don’t expect the cause to be with the installation of it.

Also you can play the campaigns without any problem.

Could you post a screenshot of you random game settings (the screen before you press start)?

Here are screen shots of the settings menu, and the random map before I click “Start”

!

It happens with all gods and all civilizations, all maps sizes, all types of maps and all difficulty settings.

I would really love to play the game again…

This is the game settings. I can only upload one picture per post seeing as I am a new member.

I have tested your settings and they work for me without any problems.

So there must be something else going on. What is your Windows 10 version and build number?

Search for winver with Cortana search glass and open it. Please post back the results.

Could you also share some additional information about your laptop?
Brand, model, CPU, type of GPU etc.

I am running Windows 10 Home.
MSI GP72 6QE Leopard Pro
Processor: Intel Core i7 6700HQ 2.60GHz
Ram 16GB DDR 4
Nvidia GTX950M Graphics 2GB

Winver just throws out a tab, "this product is licensed under the Microsoft Software License Terms to: Me…

It also shows this.

image

I have found the support page for your laptop. Please check if BIOS and Intel ME firmware are up-to-date. Also I would recommend to check for other driver and firmware updates if not applied already.
https://www.msi.com/Laptop/support/GP72-6QE-Leopard-Pro#down-driver&Win10%2064

And please also report back your Windows version.