Cannot change game speed when spectating, stuck in fast forward

Game Version:

  • Build (101.101.34397.0.454667)
  • Platform (Steam)


When spectating a match, the playback speed buttons do nothing. The game goes fast no matter what, causing stutter (similar to the way the ECL showmatches went, except it goes faster than 1.7x this time). Here’s a clip of the issue

Reproduction Steps:

  1. Join a game as a spectator in the spectate games tab
  2. The games play back at a faster than normal speed

These are my specs
Ryzen 1600
GTX 960
12GB Ram

I tried disabling all mods, checking files integrity and also tried reinstalling the game. Nothing fixed it.

I’ll try formatting my whole PC now


I am having the same problem. Not only on spectate but on replays aswell.

Any solutions so far?

“Fortunately”, formatting my entire PC and installing the game again worked. This is, of course, not a practical solution, and I don’t know why reinstalling the game before formatting it didn’t fix it.