Cannot install Age of Empires II Definitive Edition from the Microsoft Store

Hi all,
I have bought Age of Empires II Definitive Edition from the Microsoft Store. I have deleted to recover space on the disk and now when I try to install it again, the download last 2 seconds (so it’s clear that it won’t download anything), the Microsoft Store says that the product has been installed but there is no “start” button and the there is no fingerprints of the product in Windows (10, latest updates installed).
I have tried already to reset the Microsoft store but without success. How can I get support? Has someone in the community already had this issue?

Hey, welcome!!

How do you ‘deleted’ the game, exactly? Was it through normal unnistallment?
The game FAQ has some solutions to common download issues, check it out.

Hi there,
Right click on the start menu item and choose uninstall :slight_smile:

Seems that the Store still thinks that the game is installed, right? Can you find it on the ‘Add or Remove Programs’ at the control pannel?

Also, have you tried any of the FAQ solutions?

Thanks again for your feedback :slight_smile:
I tried all the steps suggested in the “troubleshooting game installation” FAQ but nothing: if I go to the store and I search for the game, it is founded, but then the download finish after few kb: no items are added in the start menu and the “launch” button in the store is missing.

Have you tried to update windows? I used to have problem to install games bought from MS store. Then I updated my windows and the problem have been solved.