Cannot play due to problems with another running process

I tried. It didn’t work, the error remains.
I also tried to close Onedrive and firewall+antivir.

1 Like

I had this too.
It is really this problem:

If you’ve whitelisted Age of Empires: Definitive Edition in your antivirus before please be sure to update the file path to:

c:\Program Files\WindowsApps\Microsoft.MSDallas_1.3.5314.2_x64__8wekyb3d8bbwe\

1 Like

Read all about it on the support page:

option 3 from titel: “the app crashes soon after launch, or when trying to start a game.”

Check your antivirus settings.
Some antivirus programs may prevent the game from launching. Check your antivirus settings to make sure Age of Empires: Definitive Edition is not being blocked.
Add the game to any whitelist feature in your antivirus program. (Note: some antivirus programs may remove Age DE from the whitelist when you update the game. Double check that the game is still on your whitelist!)
Here are a few particular antivirus programs with known conflicts, and resolution steps for each:
Avast: Age of Empires DE must be added to the program’s whitelist.
Comodo: disable shellcode injection detection.
F-secure: Age of Empires DE must be added to the program’s whitelist.
Trend Micro: follow the steps listed here.


The Trend Micro instructions are no longer there. The link is basically dead. Are there other instructions listed elsewhere since I have Trend Micro and the link is useless?

1 Like

10/11/18: TrendMicro link is still dead and still no fix?

1 Like

The new forums broke links to the old forum. The topic still exists here:

If there is another broken topic link search the forum by the title in the URL for the new forum link.

The team is aware of this issue.

1 Like

interesting issue, did you get it resolved

1 Like

This is ridiculous. I just want to play the game. I’ve done everything in the list above but when I go to my firewall options to try and add the AoEDE file to the exception list is says I don’t have permission to access the file even though I just went through every step to make sure I did. Shouldn’t have to do this. Please someone help, I’m going crazy!

Edit: When I go to the properties of the AoEDE file it says my admin account is the owner but still won’t let me add it to the exception list.


Which antivirus program is installed?

1 Like

Trend Micro. I’ve been into the settings of that and tried to add the AoEDE file to the exception list with that as well and I get the same problem.

I’m definitely logged into an admin account and when I check the AoEDE file it says the owner is me and that I have full control. :frowning: So Confusing. Any help is greatly appreciated.

1 Like

Problem folder is hidden and special system folder, but explorer and folder browser is not launched elevated, even not when signed in as administrator.

First option to try is launching Trend Micro elevated (right click and choose run as administrator) and then change Trend folder exclusion configuration settings, but probably in this case it won’t help as it just gives access to the Trend GUI configuration part that is already running in non elevated user mode.

So if that not helps, you will find this link helpful, it uses a registry tweak to temporarily adjust access. It should help you to be able to browse the WindowsApps folder with Trend and then select the correct folder.

Personally I would advice you to get a better antivirus program. It’s not operating conform latest Windows 10 application design principles.

1 Like

Thanks for that but I already have access to the WindowsApps folder.

I got access to WindowsApps folder
Found AoEDE.exe file and followed same process so that I am the ‘owner’ and gave myself full control
Opened firewall exception list
Navigated to AoEDE.exe file
Tried to add AoEDE.exe file to exception list
Says I don’t have permission to access that file.

It’s literally the final step from the list above and it won’t work. I just want to get it working considering they don’t offer refunds.

1 Like

I’m sorry that I can’t help you more with this. One more thing.

Trend also has an option where you can exclude a filename without entering a path.

What happens if you put the name AoEDE.exe there?

Otherwise you still could temporary disable real-time scanning in order to play the game.

1 Like

Great! So it works when I disable Trend completely but I can’t find a way to to exclude a file name without entering a path. If you have a link to where you found that information that would be great. I have Trend Micro - Maximum Security which seems to use a different interface to other versions.

At least I know I can get it the game to work. Would just prefer to have virus protection enabled while playing though.

Thank you so much for your help.

EDIT: Got the .exe file added to the exception list and the game would still crash. Looks like my only option is to have trend disabled if I want to play.

1 Like

Point 6 at link below, you should be able to type just the name of the executable. Also you could try manually typing the full path (you can copy by clicking on path in the bar at the top of explorer window). All sub directories need to be excluded too.

Taken from docs at:

At least you are able to play the game now. Problem might be solved with next Trend Micro AV version.

1 Like

Tried all that. The exception on Trend, stoping real time scan, dropbox, and still get the message.
Please help!

1 Like

I would uninstall Trend for a while and rely on Windows Defender.

Also after removal of Trend and reboot I would first perform a second opinion scan by installing the free application in the link below.

1 Like

Uninstalling Trend did the trick.
Without it and also with the malwarebytes I was able to play normally.

But in a near future I want to reinstall my Trend, so somebody needs to report this to then, so they can fix it.


Thou should report this at Trend Micro. MS has no control over their poorly designed AV product.

I use ESET and never had any problems. MS testlabs also uses ESET, at least they did in the past. :wink:

Malwarebytes is an extremely well additional second opinion scanner which could be used as AV product too. The same for a product like Spybot Search & Destroy.

Malwarebytes is an typical USA product. Spybot and ESET are European products, German and Slovakian.

1 Like

Guess this ‘Somebody’ has to be me lol.

Anyway, thanks for the help!