Cannot re-install from Microsoft Store

Detailed error:
Something unexpected happened.
Reporting this problem will help us understand it better.
Code: 0x80070424

Other apps are ok to install from the store, but cannot install AOE 2 DE, purchased in 2020

What have you tried so far?

  • Do you have the latest version/patch of Windows 10?
  • Does it look like a Windows 10 OS error, a Microsoft Store error, or an Age of Empires error? (I’ve not personally seen the error before, so was curious. And/or anyone who tries to help may be curious.)
  • Have you tried to uninstall AoE2:DE first, and then re-install?

I have no idea what will solve this or what could be the problem, but just wanted to mention. I have the Steam version, so I can only only know/say so much.

I think you should probably look through the AoE2 support page. I found this page, for example; which sounds similar but not the exact same error code… but it might work or be helpful for you:

If that doesn’t sound like your issue and you don’t see what you’re looking for elsewhere there, then I’d try to find the link in the Support section to fill out a form to file a ticket with AoE Support personnel and a support agent will probably email you back relatively soon.

Please know:

  • I searched the AoE forum for that Code #, and didn’t find anything.
  • I searched Google and found some results. You might try that also, if the above Support page doesn’t help.

I also see this Microsoft Support Page, which, again, is a different error code but sounds similar. Might be worth looking over:

PS: Also, no idea if this site is legit or gives legit info, so will just post a screenshot rather than link to it. There was more to this page, but my screenshot can only go so far. (It seems that error code has been in existence for several years… but its meaning or trigger for occurrence may have changes over the years? Not sure.)

 

Best of luck, @CarminePhone! If you discover what works, it’d be great if you posted the solution here, in case it helps someone else in the future :smiley:

Thank you so much for this information, I really appreciate it, since noone seems to understand this error. I’ve tried everything under the sun except re-installing Windows 10, which I’m not going to do. You’ve given me a few more ideas to try before I give up on this game and Microsoft. Thanks.

1 Like

Oh, you bet! Yeah, I highly doubt you’d need to re-install Windows 10. I can’t remember the last time I’ve re-installed Windows to fix an app/software issue (or driver issue, etc.)… and pretty sure I’ve never had to do it. That’d be an absolute last resort after everything else has been exhausted :smiley: I’d break down and buy the Steam version and play that as a last resort before doing so :wink:

Fixed my problem !!
Windows “restore point”, back to a point before I had the issue. Was now able to install AOE 2 DE again up to the latest patch. Then windows update again to get latest windows stuff and puff everything back to normal. Only glitch was that my taskbar stopped working, but was able to re-register it and that was it.
Thank you.

1 Like

Sweeeeet!! Nicely done :smiley: Enjoy the AoE2:DE gaming!

1 Like