Can't attack certain enemy units bug

I got no info other than this clip I took.

1 Like

Thanks for the video @LINGLING2688! Can you tell me if this was an AI or player? Do you know what specific civ/unit that is?

The orange player is China’s Zhuge crossbow, the purple player is like France
Because the purple crossbowman has a shield

i’ve experienced this as well, it’s also fairly common with mangonels. i think its a bug when the unit being targeted is too far away. when you move the unit closer and try again it works

I have experienced this as well, what I have to do same as like @ArtfulChaos9 said : to move the unit closer to the opponent unit. right-click attack target is sometimes not worked currently if your unit is far away (given said that in my opinion in the clip the distance between blue spearman and the purple knight is not far).

In my opinion, it should work within the the line of sight of the unit.

IDK it should be the game mechanic in AOE4 or there should not be like this, in other AGE games it is worked.

yeah, it worked at the start of the game as well, it’s a new bug as far as i know

I think there is a problem because of spearmen’s brace against horses. At the moment you click attack at horses spears brace (I think they brace only if horses have charge available). That should be why spearmens didn’t follow - they stay braced. And why they didn’t run at knights because knights had all the time charge up. They run at siege so no charge there and after killing only nearby units so there is no charge available. So in my opinion spears brace the whole time expecting charge.


Thanks you @DentingOrchid7 , that make sense

hey sorry wasn’t watching the thread. this is a 4v4 and I believe they might be French royal knights. And I think the Abbasid (me) spearmen are bugging out as if they’re bracing? not sure.

1 Like