Cant change language - Game Pass

Im using xbox app on Windows 11 to play the game. I tried to change every Windows setting to english. Tried even reinstalling game and wsreset command from FAQ, but still nothing.

The language still remains Russian. Could you please help me???


Same here, when trying to switch from german to englisch.

Same thing happening here. Can’t change from Portuguese to English. Can’t see any reason why the option to change languages doesn’t exist in-game.

Edit: I’ve tried everything mentioned on the official help page and still didn’t work.

1 Like

Same issue, my game is stuck in Japanese even after uninstalling all languages other than English.


  • Everything on the help page
  • Reinstalling/redownloading the game (multiple times)
  • Deleting save folder
  • Installing Spanish and making it the primary language (made the Xbox app Spanish but not the game)
  • Running wsreset
  • Turning automatic updates on and off

On Windows 10 using game pass.

Hey there, if you haven’t yet, please try the steps found here:

Already tried everygthing suggested on that thread. Even reinstalled the game after adding the language on windows’ settings. Didn’t work

Have the same issue. Can’t change from Russian to English.

Even when I close the game, I can’t switch the language from Russian to English in windows 11. The language switch in the system tray also disappears. Only restarting the computer helps.

1 Like

I had to set English as my favourite Windows language first, open Game Pass and it was in English then, but game still wasnt. I waited about 5 minutes (thinking perhaps it was downloading) and then rebooted my computer. It worked.

But now I have my computer in English which sucks as other household members do not speak it and my keyboard is set to english everytime I boot.

Can we please just switch the in game language??

1 Like

Same here i’m in english and I want French.
Articles are wrong and didn’t resolve the issue.

1 Like

Hello, everybody

I don’t know if this could help with your problem but for me it did.

So, besides following the official instructions from the support (Mainly putting the language you want as preferential and first in the language settings in Windows), and after that I needed to restart the OS for them to take effect.

Hope this helps :smiley:

And sorry for the English. It’s not my first language :sweat_smile:.

1 Like

yes, a restart is mandatory for Windows language change

Restart did not fix the problem !

My windows is already in full french everywhere, before and after restart.

Hello! I have the same issue- I already had English set as a language (Region Austria), but the game was in German.
Went through the article linked, changed the language to English (UK) just to be sure it’s not some kind of region thing, did not work.
Ok, reset the store with the console command, rebooted, still, no language pack being downloaded or installed, game is still in German.

Please fix this, I’d like to play all games in their original languages, as dubs are simply inferior in general.

Thank you!

Are you sure both the Displayed and Preferred languages are set to English? It must look like this

English must be at the top of ‘Preferred languages’

Yes yes and yes … (I’m looking for french/France language)

Hey all!

If you are still unable to get the correct lanugage to display, could you please contact support here with a summation of your problem and your DxDiag and any Crash Logs?

It’ll be tremendously helpful!

Thanks so much!

Guys, it works!

1 Like