Can't link my Microsoft/Xbox live account

The sign-in window opens from its own web browser that’s included in the game install, “WebClient.exe” in your AoE4 folder.

1 Like

In that case checking the Internet Explorer settings probably are still applicable and does make sense.

You can also link the accounts using the Age of Empires Insider website. As a matter of fact I noticed that my account isn’t linked to my steam account anymore too, so something went definitely wrong there.

Maybe if linked through there for the time being this problem is solved through that a work-around. Just read this one on Reddit somewhere, so not sure if it works.

You can link it here. Scroll down to add a Steam account.
Profile - Age of Empires

no that is not the problem

other xBox Live games are working fine like AoE 1, 2 & 3, Gears of War 5, Gears Tactics and Halo Master Chief

This is a problem only related to AoE4

1 Like

Yet not for all the players, which still is remarkable.

Also it’s strange it didn’t appear at the beta or stresstest. Something must be blocking that web client from functioning properly.

Could we please have a Dev update on the status posted daily?

It seems like issue does not apply to every player.

3 Likes

Having the same issues here. I have screenshots in this post:

I have the same problem, sent a ticket but no was provided just “we are working for you” can you fix this? I can’t play since launch despite try everything

Same here, having this error since launch!

I’m sure this is a widespread issue that will be fixed in the backend of some server or in a future patch. I would just wait for now.

Same Bug with me too. Hopefully they can get this fixed soon as I cant see my elo and leaderboard rank until accounts are linked

Still no fix after several days? Sad!

1 Like

There was an update today and still this is broken.

In addition, I think this might be connected to why I don’t show up on the ranked ladder - other people have listed ELOs and win rates but I can’t find my own. My thinking is that this same bug is involved.

2 Likes

Same issue here! when is the fix?

Some communication from devs would be good…

2 Likes

There is some hotfix action going on behind the doors apparently! according to https://steamdb.info/app/1466860/history/

1 Like

Do you have 10 games completed? That’s the condition to show up on the Leaderboards

More than 10. I’m not the first to mention not showing on the leaderboards.

same here. can’t link steam to xbox live

Issue still persists after a week. I have logged in and out of Steam and any Xbox related apps or websites. Linked my accounts on ageofempires.com and tried to unlink/link other AOE titles without success.

To the best of my knowledge perhaps some old insider build license is preventing the 1.0 release build/license to link?

Same issues here. Never installed any of the betas, and clean Windows 11 install from about a week ago. Also use the same MS/Xbox account to login to my PC. Don’t see any friends in game at all (Steam or Xbox), no achievement tracking in the Xbox app etc.