Cant open the game

yesterday it worked. but today my aoe2 DE wont open, does the whole steam “preparing to launch” and then disappears and nothing happens. Tried reinstalling visual 17, tried reinstalling the game, tried verifying integrity, tried updating windows. Anyting helps thanks. I also am wondering if my aoe updated cause i know update came out but i didnt have an update. But i reinstalled so that should help?

Having the same issue, was hoping the latest update would fix it but still no luck, I have tried everything recommended with still no luck, i want to play this game so bad…

I solved this problem by starting the game without mods (Probably some are incompatible with the new version of the game).

To try this solution, edit the file mod-status.json in the folder :
C:\Users\userName\Games\Age of Empires 2 DE\userID\mods\

You can then set the value to false for the field “Enabled” of all your mods.

So I don’t know exactly what fixed it for me but I forced closed everything I could find in task manager. And it worked for now. Seems like certain programs interfere with it opening.

Is it possible at all for you to give a list or run down of what you forced closed? I have had issues in the past with lightingservices.exe triggering the anti cheat in some games but this doesnt seem the same, as when its lighting services a window will pop up to say thats why it wont start.

A list would be super helpful so i can cross check if I am having the same issue


If you subscribed the AOK Main Menu mod , please edit this file :
C:\Users\UserName\Games\Age of Empires 2 DE\UserID\mods\mod-status.json, and set the value to false for the field “Enabled” of the AOK Main Menu mod.

{“CheckSum”:“0”,“Enabled”:false,“LastUpdate”:“1583427499733”,“Path”:“subscribed//3738_The Age of Kings Main Menu”,“Priority”:3,“PublishID”:0,“Title”:“The Age of Kings Main Menu”,“WorkshopID”:3738}

I’m sorry to have made you difficult, I will update my mod soon.