Can't save custom hotkeys in AOE2 DE

Game Version:

  • Build 101.101.33315.0.0
  • Platform XBOX GamePass


I create a custom set of hotkeys but the game doesn’t save them. Launching the game as administrator does not help.

Reproduction Steps:

  1. I go to the Hotkeys tab in-game.
  2. I change whichever hotkey I want.
  3. I click Confirm.
  4. I try my hotkeys. They work.
  5. I exit the game.
  6. I launch the game.
  7. I go to the Hotkeys tab again.
  8. I realise that my custom hotkeys have reset.

These are the hotkeys I set, but they reset back to the default ones for some reason.

I have some solution, but this is just makeshift

  1. Make one more profile as dummy
  2. When play game, select your own profile
  3. Before turn off game, switch into dummy profile and exit (very important)
  4. Launch game and select custom profile. it will be saved

caution: if process 3 not be done, your profile will be reset (including Crash to Desktop)

1 Like

This actually worked. Thanks a lot!

Wow. I hope this will be fixed soon, I have fully customized hotkeys and basically cannot play nor practice on DE because of this bug.


scusa non ho ben capito…
1: io creo i miei tasti chiamati esempio prof1…
2: creo un altro profilo fake es prof2
3 : gioco con tasti prof1
4 prima di spegnere il gioco devo passare a prof2?
poi creo un prof2… e poi tutte le volte che gioco prima di uscire devo passare da prof2?
5: accendo il gioco vado su prof1 e funziona tutto ?
ho capito bene?

Will this issue be fixed in the upcoming patch?

SO !!
I can’t count the number of times I had to redo my hotkeys (I’m french so I have to switch everything to AZERTY) or the number of times I crashed while switching Keybind profiles. I used the workaround of @RynexWon (which works) , but kept forgetting and losing my custom keys.

I FINALLY figured out how to fix this issue, at least it worked for me. Here is how:

1- Create a new custom keybind profile (for example “AoEKeys”).
2- Set your custom keybinds and confirm.
4- Go to your windows search box and search for the file (“AoEKeys”). In my case, the file was located at -> C:\Users\ InsertYourUserName \Games\Age of Empires 2 DE\2533274909600602\profile
5- Go to file location and SET IT TO READ ONLY
6- Make a copy of the file to your desktop or where ever you want (for extra safety).
7- Confirm it worked by restarting the game. If not, may God have mercy on your soul.

This worked for me, it’s rather simple but it took me ages to even think of, as I originally looked for the file manually, and there is another custom profile folder (C:\Users\ InsertYourUserName \Games\Age of Empires 2 DE\0\profile) which is NOT THE RIGHT ONE, and probably the one causing crashes.

Hope this helps.


edit : this is for Xbox platform


You just made the game playable from an unplayable state, ty so much.

Happy I could help :slight_smile: