Can't Scroll Anymore (by mouse on border or keyboard)

Game Version:

  • Not in front of my computer now, sorry, but last one dowloaded the 19-12-01 :slight_smile:
  • Steam


It’s a weird bug downfalling from a series of previous bug, here is the entire “story”:

• I was using the Scenario Editor

• It just crashed (no warning, no error, just full and sudden shut down)

• When I reloaded the game, it was windowed. I resized it full screen:
The UI lost the scale (it was smaller and buggy)
I lost a lot of graphical parameters
The game changed language (???)
Just by resizing the window…

• I started playing a multiplayer game, I realized nothing was working correctly, went to the option, everything was unchecked (two mouse button, lots of gameplay options, etc.)

• I re-checked/unchecked everything to have proper parameters… and the only thing not working anymore is: I can’t scroll the screen.
Either with the mouse on the screen border or the keyboard.
With the screen border or not option checked AND unchecked
Windowed or Full Screen.

It just never works.

I verified the files integrity on Steam: still doesn’t work
I uninstalled the game and reinstall: still have the problem
I uninstalled the game and deleted everything AOE2 related (%appdata% files, users/doc files, steam common files, etc.): still have the problem…

I’m a bit stuck and I obviously can’t play at all (except clicking on the minimap hehe) :slight_smile:

Reproduction Steps:

Just launching any type of game, solo or multiplayer, checking/unchecking every parameters that could influence the UI/Mouse control. Even tried with other keyboard shortcuts, etc.

(won’t help I think :slight_smile: )

Thanks a lot by advance !

1 Like

Excuse me but…
Will you not even acknowledge my message ?
I litterally can’t play the game anymore, game that I bought (more than one time), participated in the beta and gave you feedbacks about it.

Does someone could at least… look at it ?

Btw I just reinstalled the game, last version, with your latest big patch.
Same error.

It’s clearly a config file somewhere, but as I said, even if I search for anything AOE2 related, it doesn’t work. Does it modify registry keys ? is it possible to reset/delete them ?

Hello developpers ♫

Still no idea about this bug ? :slight_smile:

i solved it the scrolling problem that you described I am not a developer of this game.
Go to options -> Game tab
You will see scrolling on the options
click and drag scroll speed from 0 % to 50 percent, and you can also change the inertia.
I don’t know why the game does not change this back to default.

Nice that u managed to solve this. I had a similar problem happen to me, was using scenario editor, and suddenly every setting unchecked itself, and even lost some functionality like game not showing notifications.

Can you check if you also don’t see ingame notifications at all? (for example the text that appears in the top left and lists --Villager Created --Farm Built --House Built etc…). If you do have that issue, you can solve it by deleting the AdditionalOptions.aop file, which will reset all the options of the game, but brings back notifications

This happened to me today. Just chipping in to say it is still a problem.