Can't sign in to Xbox Live on Age of Empires II: DE

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 6624001
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Whenever I click on “Sign into Xbox Live” on Age of Empires II DE, it brings me to this sign in screen pop up. Clicking allow on “Let this app access your info” brings up this “Script error” popup from Internet Explorer. Internet Explorer is not my default browser.

This doesn’t happen for other Microsoft app sign ins.
“Object doesn’t support property or method ‘has’”

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Click Sign in with Xbox Live
  2. Click accept on the agreement
  3. Get popup error

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

1 Like

I’m having this exact same issue, same line, char and error, I have no idea how to fix it, hoping someone has some input.
tried clearing cache from internet options, tried uninstalling and starting again, checked if a different account was logged in on the console companion. none of these worked for me.

I’m having this exact issue as well on age of empires 3 definitive edition. I have tried clearing cache/cookies. Reinstalling the game. Restarting computer. Signing out of xbox app etc. Done everything I can think of, to no avail.
I was signed into xbox live with no issues a month or 2 ago. Then the game signed me out at some point, not sure when (Probably when the game had an update and screwed it all up). Whenever i try to sign in to xbox live on AoE3 definitive edition, I always get this script error when trying to allow the game access to my info.
Glad it isn’t just me getting this issue.

I solved it. Hope it works for you too. (I do not know English, I speak with translation.)

First, click properties with a right click.

1 Like

Copy the marked place in the picture and open chrome browser


It does not progress after logging into the account, do not panic, go back to the game and try to open your account again.


Had the same error, but in the first game, Tried this solution and worked, thanks!

1 Like

That worked perfectly! thanks so much for that!

1 Like