Changing Hotkey Defaults does not work, stuck in "Classic Hotkeys" and can't switch to "Definitive Hotkeys"

This doesnt seem to work for me. I replace the hotkeys file, but i still got wrong hotkeys…

So as I mention earlier, you HAVE TO DELETE FROM IN-GAME, and here is link which I used and it still work, so please dont hate instead work on solution lazy :slight_smile: Also you can find all kind of hotkeys just GOOGLE-ING THEM…

@TL013 what do you mean by ‘delete from in-game’? That is not clear to me

I cant delete the profile, i got the following message:

image

Any solution for this one?

Yea that’s ok I had that too, you can leave one

So, did it worked for you ?

Same problem here. This is a game-breaking bug and should be addressed ASAP. None of the listed fixes worked for me.

:roll_eyes::roll_eyes::roll_eyes: Nemam vise zivaca…

After further inspection, I found that the only hotkeys that get messed up are the “Villager Build” hotkeys. After realizing this, I just asked my buddy to read off the list and I copied his working set of hotkeys. My hotkeys now work totally fine

Here is a link to an image for the correct hotkeys for “Villager Build”, hope this fixes it for you guys.
(tweaking this message a little because I made the same comment on another thread and it doesn’t like repeat posts.)
Imgur

I finally got one hotkeyfile that works… good thing i have a friend that hates changes and never touch like, anything in settings. I want my vills on a, building and military buildings on a/s. I want to be able to stop buildings with delete. This bug felt kinda dealbreaker, i was about to stop playing…

with the good old, a-a = farm etc, if theres anyone else having trouble finding it…

This needs to be adressed! Over a month old??

Sorry for ignoring your post. I havent tried it yet. I have manually set some hotkeys, which kind of solves my current issue.

Any news on when this is going to be fixed?

I have the same issue as the others, I have tried all the workarounds others have tried, and this still does not fix the issue.

Where are you from ?

I am from the united kingdom.

Send me your number if you want me to help you

I got this issue as well, so it’s not a one-player bug. Hopefully this gets fixed in future updates.

Looks like this is fixed in the latest update. I tested it and it seems to work properly for me now.

Hotkeys can now be correctly reset to “Definitive Hotkeys” (grid layout) again.

1 Like

i tried to fix this, and with some help on this website: https://aokhotkeys.appspot.com, i made!

use this two to set the hotkeys:
|ZeroEmpires|HD5.0+|
|Forgotten Empires Default|AoC/FE|

economic build - A
militar build - S

TC vill - A

farm - AA

use the tutorial on the website that teach how to place the generated hotkey file on the folder:

C:\Users\YOURUSER\Games\Age of Empires 2 DE\9999999999(YOURSTEAM ID)\profile