Changing Hotkey Defaults does not work, stuck in "Classic Hotkeys" and can't switch to "Definitive Hotkeys"

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD #: current
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
Hotkeys seem to have reverted to old school where “q” then “e” builds a house. This happened for both my brother and I, but our friend has not had this issue. When we try to change to back to the grid setup, changing the hotkeys in the settings doesn’t work. Going to “definitive edition” hotkeys doesn’t change, it stays as “q” “e” to build a house among many others not being grid set up. We tried changing to HD and nothing seems to change there either, so the hotkey profiles seem to be messed up?

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!
Ongoing and we can’t seem to get the hotkeys to change to definitive profile, if that indeed is the “grid” style setup.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!
The only thing I can think of is that my brother and I enabled some mods, and my friend did not. We have since disabled them, but the bug persists. Mods I had tried installing: Small Trees, Mouse Cursor Set, Useless Plants Remover, Interactive Build order Guide, Advanced Idle Pointer, SmoothieDE with Light Grid, Impoved Tech Tree UI, and No Snow. I have since disabled the mods. However the problem persists.
Here’s the steps to reproduce the issue:

  1. Go into options.
  2. Click “villager build” see that Fish Trap is “Q”, and house is “E” which is not what we previously used.
  3. Choose Default says “Definitive Hotkeys” Click this and reselect it, hit reset all, nothing changes.
    4.Try changing to “HD Hotkeys” again, no hotkeys seem to be changed.
  4. Try Classic HOtkeys, same, nothing changes.
  5. “Left-handed Hotkeys” does indeed change the hotkeys.
  6. Change back to “Definitive Hotkeys” appears to change hotkeys back to “classic edition” instead.

:arrow_forward: EXPECTED RESULT

:point_down:I expected switching to “Definitive Hotkeys” would create a change in the hotkeys such that for things like building with a villager, the optioins for villager actions would be in a grid layout in relation to the keyboard.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.
This is not an in-game issue.
*

3 Likes

I have also encountered the issue described above.
I remapped one of my mouse buttons during one session, the next time I loaded the game the hotkeys were all reset, and the Definitive Hotkeys defaults will not load.

1 Like

I have also encountered the issue described above too.

Hey everyone,
thanks a lot for this report, luckily this issue is tracked already :slight_smile:
Have a nice day!

1 Like

yeah but when?? this is really game breaking. I havent play the last 2 weeks because of this. Plase fix it, it shouldnt be that hard. if the lefthanded keybindings are working just use the same logic to the definitive edition keybinding, but with the correct default set. Just sent small PR with the fix, even if it is not in the priority pipeline. I know must players dont have this problem, but the fix is so simple.

4 Likes

Hello,
my brother and me found the solution. You need a working copy of the hotkeyfile (Hotkeys.hki) and overwrite the original one at C:\Users\NAME\Games\Age of Empires 2 DE\XXXXXXXXXXXXX\profile.
You can get it here: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Good luck and have fun!
Cheers

1 Like

I just signed in to say that I have the same problem and it is still not fixed.
Replacing the Hotkeys.hki file does not work for me. I even downloaded some custom hotkey files from pros
and even those are being overwritten by classic hotkeys.

Exact same problem here

I first deleted AOE from Steam, deleted the game folder under User/Games, reinstalled the game then replaced the hotkeys.hki file.
Maybe it works this way.
Or maybe you need a copy in your language, my version is from a german game.
Good luck.

I also have this issue. Any updates on when there might be a fix?

Found a workaround!

Get a hotkey file (mine is almost the one of DE):
https://file.io/BnLp3nnSTphd

Then paste it here:
C:\Users<your_name>\Games\Age of Empires 2 DE<your_id>\profile

Guys I solved it, just delete all hotkeys profiles in game first then paste it in up mentioned folders, let me know if solved, glhf

I experienced this issue after a friend asked me how to change them. I tried changing the layout and everything reset and can’t be fixed to what I previously had.

I had been using the grid layout and even the economic and military buildings are getting switched up. I would consider this gamebreaking.

Edit: None of the solutions listed worked for me.

1 Like

It works, you need to delete that when inside the game, not in folder

I also tried that, but the game does not let you delete them all. One file has to remain, and that’s the issue with your solution. With that mentioned, I did manage to change it from the Classic edition, although the grid layout .hki file I got from the internet was still non-functional due to game not recognizing if it was the economy or military tabs.

1 Like

Find definitive hotkeys doc, I will upload tomorrow, it doesn’t meter if one file stays the point is to paste new ones. So you only need to replace that on definitive hotkeys grid as default

Actually, I tried it again and it worked. I deleted them in-game like you said, closed the game, then I deleted all the config files where the .hki files are kept. I then validated the game using Steam and restarted the game, moving the desired hotkey files into the hotkey folder, and changed to that hotkey file in-game from the menu. This let me use the grid layout I had been using again.

I will not attempt to mess with the hotkeys again until this issue is fixed.

Glad to hear that, cheers m8

1 Like

Have this issue, makes it unplayable for me, that default hotkey file someone linked early has expired and is no longer accessible, can I have a copy of the default hotkeys?

Edit: both links I found are expired. Please if you’re going to upload a fix don’t use a temporary link! There will be people maybe years from now who might have the same issue and find your comment, thank you.

I got this issue as well. When will this be fixed?