Chasing the crown achivement not working

Yep, this issue comes from the anniversary patch and the devs don’t do anything to fix, it’s damn disgusting.

Guys, chill, I know it’s annoying, but devs like to release bigger patches monthly, we’ll have to wait till the next one, they won’t just release a patch to fix this one issue

1 Like

Yes, it still doesn’t work. Tried to earn a few others in the mean time like the sheep one for example and it didn’t work. Got 24 sheeps and didnt get the achievement. It’s annoying that it hasn’t been fixed, but at the same time it isn’t gamebreaking so i understand why devs might be focusing more on the DLC and other things. Still if this issue continues with the expantions, then I’d say we have a valid point to complain.

AS well , Same for me . “Eternal Gratitude” & " Chasing the Crown" didn’t work .

1 Like

Both issues are logged! When a fix is implemented, watch for the note in an ‘Achievements’ section of the update notes! =)

5 Likes

still not working…

The Dev said they’re logged, not implemented yet. I’m sure it will be part of the expansion update.

2 Likes

I’m assuming the same, now it’s time to try finish everything else before that comes out, in case something else breaks!

2 Likes

New update fixes both achievements, thanks devs!

Indeed, just got the achievement yesterday. Although I wonder if every achievement is fixed.