Chinese War Academy Bug

V. 100.12.1529.0 To the new Age of Empire 3 Definitive edition
Every time I play with Chinese civilization, and receive Confucius’s Gift of Gift, which accelerates technology development, and develops Hill Castle technology, a whole row of technologies that upgrade units in the War Academy disappears, making it completely impossible. upgrade the units Shangdao Swordsman, Steppe Rider, Keshik or Meteor Hammer, which makes it impossible to develop such units for the rest of the game. This bug does not occur if you have not received the Confusius’ Gif submission, but it does occur as soon as you receive it even if you unraveled Hill Castle first. It doesn’t happen with other technologies, but it happens on every map.


It’s a big bug that I’ve come across

Now I discovered how this bug works specifically, it is related to Confucius Gif, not to the fourth age or the Fort as I thought at first. Unfortunately in order to upgrade the units we cannot upgrade the Castle until we upgrade every unit of the War Academy

1 Like

Yes,i try it and bug again

i also indentified the bug related with confucius gift. furthemore, i don’t know how, but the bug occured again without Confucius gift, that make it realy anoying

This update still hasn’t been fixed

The procedure to get this bug to occur is as follows: if you upgrade a castle’s attack/HP, then order ANY home city card, the bug wipes out a row. Tried it with the current version.

Pretty annoying. Still not solved with the last version. This forces me to avoid Chines civ, one of my favourite. Soooo annoying. :face_with_symbols_over_mouth:

P.S.: I tried to create a scenario with Chinese civ with teh editor. The Hill Castle Upgrade doesn’t affect the tech in Academy when I try it. Still occurs in Skirmish.

1 Like

For me, it always occurred after building the Russian Blockhouse. I suspected it had something to do with the Russian Blockhouse training moving everything down a line and the two buildings sharing a button map, and the Blockhouse updating the button map for everything despite the Academy not getting everything, resulting in the Academy moving things down a line for Banner Armies it can’t train.

I tried those steps and nothing happened for me

It occures whenever I pass the 4th age for myself.

It has nothing to do with the Confucius gift. Upgrading anything from the Hill Castle causes the last row of upgrades in the War Academy to shift downwards. I would recommend not touching any upgrades in the Castle until you’ve gotten every upgrade you needed from the last row of the War Academy.

Not just anything, I tested and it is specifically Hill Castle technology, but apparently this bug can occur in multiple ways

Hill Castle or not, I have not seen the upgrade buttons to the four units mentioned. I was expecting this to be solved soon, but so far nothing.

Too bad, because military units is what makes China interesting to play with :confused:

1 Like

Hi guys. I tried to verify if with the last update the bug still occurs. It seems finally solved.

1 Like

Unfortunately it wasn’t

That’s weird! I’m gonna try to reproduce it again and see what happens. Since the release it was the first time that didn’t occur to me.

You’re right.
After the patch I tried Chinese civ in deathmatch mode starting at age 2, just to rush to the hill’s castle upgrade and the upgrades in the academy did not disappear. Maybe it occurs just in the skirmish mode by starting from the exploration age.

P.S.: Damn.

same bug

It seems solved with the very last patch. Finally! :relaxed: