Civilization Alliance mods are not giving any special buildings for the picked alliance of more civs

We are unable to build no more special buildings even if we pick alliance. Like no feitoria for portugese civ, no donjons for sicilians and no folwarks for poles

Yes, I tried too. Its not possible for winning without special buildings its like cutting out the civ bonuses for the 3x 6x 10x or 50x bonuses and just put the unique techs.

This isnt an official mod. It isnt made by the devs.
After a new patch modders need to update there mod as well. That takes time.
Instead of complaining here, you should contact the creator of the mod.


Its not a complaint, we are just expressing our views so our voice adds on with others too and lets our voice hear out louder, may be a way to express more intellectual views to the creator of the mod.

But yeah, he might have not created only this mod, why should he have changed only this mod?

As per my knowledge there are 15 such mods which uses Civilization alliance. So there is smaller scope that he have only created Civilization alliance, so there must be a bigger scope that he have created many such mods but only changed this mod.

There are many authors regarding this mod Civilization Alliance. The list of Authors are nearly 8 members as follows:

Emillio Miyanni
Rooky Burrito 243( created twice)
Wipelt 7314
Scored Father( created five times)
Utility Pigeon 46 ( created twice)
Coated Titan 8845( created twice)

Why won’t I get reply in the section of mod discussion from none of these people at least one? BTW all of a sudden who could have changed the mod abilities in all the 15 mods using Civilization Alliance. It was running good and perfect even before 2 days. And I m not getting not even a single reply in the link attached since 2 days.

I can give you a simple answer to most of your questions…

The Authors of these Mods DO NOT get paid to create or fix them, and while is a good idea to mention the issue, expecting a quick response or resolution is not.

Keep in mind the authors, have full-time jobs and families, this is just a hobby, not their job.

BTW every new update will affect some mods, campaigns, or maps, nothing we can do about it… Except to be patient and hope that the creators of these mods have the time and willingness to update them.

So, let’s wait and ask politely to please fix them/update them As Soon As Possible.


I agree to this, because as soon as the update for armenians done, the things have changed. But…

But there are several other mods that uses the same ability to share the civs, like 10x shared, 50x shared. They are all working as good as they are before.

Yeah on overall I doubt it now, only because of the update of the whole AOE 2 DE may be the cause, I thought. the only mod was not working is this mod, so modding might have been the root cause. Thanks for the clarity :slight_smile: .

But still I am very upset, Its like the earthquake broke only my house :frowning: . Even though its weird to seek help in this situation at least one reply would be good enough that its not the problem with the modding of this particular Civilization Alliance.

Lets hope the best that they took a look at it ASAP and waiting for few more days might never be a problem :man_shrugging:

I understand your frustration…

With every new update I see more of my favorite mods, campaigns, maps, or triggers being affected.

But there is not much we can do, since we can not expect developers to check and test every mod, nor expect for unpaid creators to fix them every new update(assuming they are still compatible or fixable)

It is frustrating, but as mentioned by @WoodsierCorn696 try sending a polite notification to the author, hopefully, he/she is willing and able to fix it.

I used the mod discussion which is in the link, not yet got an idea how to reach one of the 8 authors! Please feel free to explain me how to reach them.

What it would take to re update again the same, but this time including no effects to this mod? Could it be a lot of difference to the burden for devs? Or by chance is there a way that its not even a heck of work to do?

Go to your icon on the upper right hand, find the mail Icon (envelope) then to the right find the second mail icon, hit it and it would open a new box, input the name.

Try sending me a message to tested.

I just send you one

1 Like

Ok I try with a new mail.

I do not know the aswer…I would guess that depends on the update…sometimes may be something simple…but it coul be not compatible at all…

1 Like

Thanks to all. The mod is working fine and all set once again. Thank y’all for your kindness and co-operation. The update made today fixed it. Thank you more and more again.