Clicking behind buildings

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD [Version shown in menu: 101.102.20078.0 (#85614) 11375994]
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


I got back after break, I went off like 6 weeks ago or so when RoR came and make huge new bugs, I returned and I feel very unfamiliar which such behavior of setting gather point not only on TC but it is the most building I feel is not right as it should be, when I am trying to set up gather point behind building.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Select TC
  2. Click behind it (like you want to set gather point behind it)
    3.It allways set gather point inside TC which makes micro of units when playing impossible

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Gather point should appear behind TC (I played like 6 weeks before and got break returned and it feels very broken or diffrent than I remember)

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.


Have the same issue with hitboxes for buildings where it is even more difficult to select a villager behind a castle, or a boar they’re gathering from. Mouse clicking around objects less accurate than before, building foundation hitboxes bigger and very annoying.

1 Like

though recently theres a bug where clicking on transparent data on completed building result in clicking on building itself, this video hwoever isn’t a bug and it is by design.

the game is to click on the building (garrison, or attack enemy) if you click on the pixel and thats just how it is. im not sure if they can fix this and would want to, game has worked this way for 20+ years.

Press Alt for that when controlling units, alt makes it so building hitboxes are ignored.

I would also suggest testing the set gather point with alt pressed down. Because if that makes it work, it’s kind of a non-issue just takes you to use the buttons that already do stuff to your advantage

But I do agree that the Hitboxes of Buildings is too large, you can clearly notice this that ground parts where there’s normal map ground doesn’t sometimes have a hitbox at all.

@NoraLoralei I tried with alt but it’s not icluded in video, because alt works diffrent than I remember with building and I preparing new report. Alt apply only for units not for gather point, only building hitbox matters, same as now castles and other buildings have hitboxes bigger than they should.

I also play this game for some many years, but after RoR I get break because of minor bugs I just got back and my muscle memory not apply. I asked my friends if they feel same and I started digging online. On internet I found that there is a bug with bigger hitboxes than buildings should have, in video you can see it clearly. The same situation for castles and other buildings. My friends agreed that this is not as it was.