Cloud storage full bug drops player, unable to delete cloud storage

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: latest build
  • GAME PLATFORM: both Steam / Microsoft Store
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

when playing multiplayer, error message “cloud storage full” and proceeds to drop a player randomly in the game.

please don’t simply ask players to delete their cloud. it is impossible to do as it holds old files and we have no way of doing it, been shared a lot in aoe discord and MS need to fix this thing. all save files and recorded files already deleted and still at 95%

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. play a game with 6 to 8 players
  2. have cloud storage at 95% - 99% (not of choice)
  3. play until 1 player drops when bug happens

:arrow_forward: EXPECTED RESULT

remove cloud storage or give player access to delete old recorded files that is NOT on their computer.

1 Like

I have same problem.

1 Like

Hey, this currently doesnt happen in our tests, could you tell me if this happens always in all MP games? Ranked vs Lobby? How many players have to be in game?
thx for the replies

1 Like

For me it was happening when the game was trying to autosave. I haven’t noticed it yet since the update, I’ll try to document if it does.

2 Likes

@ChristheCo thank you for responding!

so far played with any amount of people from 4 to 6 with AI, has to be multiplayer, not ranked just normal lobby. it’ll randomly drop a player whenever that message comes up telling us cloud storage is full…

in the test that you perform, are the cloud storage near full at 99%? and with recorded game checked?

Hey, we have tried it as you mentioned, but there was no error, could you submit a recorded game or a minidump from the player who crash and your logs would be great as well. Thanks!

@ChristheCo I have since disabled recording game and no drop on latest patch. I will give it a try in next few days to enable it again and if theres the drop I’ll message here, thanks for the follow up/

1 Like

@ChristheCo heres a game last night, host (Valiant Wafer) has Cloud enabled and got the message that cloud is full, and dropped one of the player (hjpotter).

heres the rec from hjpotter’s pov, disconnection time is 1:19:12 into the replay.

162505.44_MP Replay v101.101.56005.0 @2021.12.09 141529 (4) - ).aoe2record (6.3 MB)

Thats really helpful, yet for proper investigation we would need the minidump file:
they can be found in “C:\Users\USER\Games\Age of Empires 2 DE\logs” will have date-time format, something like “AoE2DESteam-51577-2021.10.07-10.11.24.mdmp”, it should be at end of the folder. :slight_smile:
Thanks for the help!

yea I have asked for the mdmp file but since im not the one disconnected file isn’t from me.

I even tried to re-enable steam cloud but its not enabling for some reason so I cant “crash” other players by having 100% full cloud :joy:

if we get more we’ll post here

1 Like

@ChristheCo @IkoKnight8151

sorry for necro the thread but this happened just today.

host (Valiant Wafer) got the message of Cloud full, and player Kton proceeds to drop/crash. We then restore the game with all the player only for all of us to desync seconds after.

have replays from 4-5 players, including the player Kton’s mdmp, save game and replay. some have 2 replays because of the first drop, and then 2nd all player desync after restoral.

1 Like

Hi @thieftdp8498

We are now tracking this issue.
Thank you :slight_smile:

1 Like