Co-op Campaigns are broken

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 54480
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Instead of the scenarios slightly modified with an extra player, the maps that are loaded are similar to an Earth map. Furthermore, when loading the map, the game shows a message with the text:

“AI Script Error Player 2 File: scenario difficulty DE.per2 ERR5001: File open failed ERR5001: File open failed”

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Set up a game in co-op mode.
  2. Start the game.
  3. An error sign appears and the scenario is different from the original map.

:arrow_forward: EXPECTED RESULT

The expected result was the creation of a game with the map of the campaign but with the only difference being the existence of one more player.

:arrow_forward: IMAGE

Hi @Inaki8293 !

We could not reproduce this issue on our side :thinking:. Could you provide to us more information? Which coop-campaings are the ones that fail?

In the meantime, I am thinking that maybe it could be a problem in your local files. Could you try to verify your files in Steam? Properties → Local Files → Verify Integrity of game files

Reinstalling the game could also help


The campaign missions we tried were Attila 1, Attila 2 and Kurikara. I’ll try verifying the integrity of the files and trying again and then, I’ll say if it worked or not.

We tried verifying game data. Both of us. The issue keeps appearing. The same error sign keeps apearing with variations. (Player 2, 4) (I am Player 1 and the other player is 6)

Further info: The map that is loaded is the Earth Map. We also tried the Hastings mission. Issue keeps happening.

I am also receiving this issue, when starting a lobby for any co-op campaign mission with an invited player. Instead of loading the co-op scenario a standard game gets loaded and then the below error message will prompt:

We’ve attempt different troubleshooting techniques like verify integrity and reinstall. This has been impacting me and another user since the beginning of the co-op release.

Hi guys, can you try this?

  1. Close the game
  2. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE
  3. Copy your user folder to a safe place, it has lots of numbers.
  4. Delete the original and open the game again. A new user folder will be created

If this works, then copy back the files from your old user folder.

Let me know if it works!

¿Age of Empires 3 DE? ¿Home Cities? There must be an error in this response. This is Age of Empires 2 DE.

Thanks @Inaki8293 , comment fixed!

It worked now. If it is a bug, i hope it get solved. Thanks for the fix!

1 Like

Hi @IkoKnight8151

I’ve tried your suggested solution, and am still having this issue. (same error message, as well as another that said “scenario market.per2”, and “resign FE.per2”, just happens depending on which co-op mission I choose). I have verified the game through steam, tried the suggested folder delete and replacement of files, uninstalled and reinstalled the game, uninstalled all mods, but am still getting errors while trying to play co-op :(.

Any other suggestions?

I’m out of ideas :cry:

Please contact with our support team, I hope you can solve your problem!

I also got this issue since last update. A friend and I played the william the conqueror battle just fine several months ago and just today tried to do the Attila campaign and ran into this issue. I tried the suggested troubleshooting and nothing changed. I will also try contacting the support team.

Problem still there; tried first “Attila the Hun” scenario (between a Steam and a Microsoft Store coop players) with this result:

  • Map is different from expected one; it has two bands of trees at the sides.
  • Population is zero instead of 200;
  • Instead of allies, the cooperating players are enemies.

Update: it works only if the Steam player invites the non-Steam player; the opposite does not work.