Connection issue since ~april 3

I’ve been playing AOE2 DE since about a month. With not too many issues, just some random disconnection or multiplayer connection issue.

For a week now it is a nightmare :

  1. I create a lobby game, game start, I play about 10 sec. Then, bam, freeze and disconnecting. I get the regular message that I’ve been disconnected from the game and a savepoint has been created for restor etc…
  2. Sometimes as well, I access the lobby now, no game shown. If i want to create a new one… it stays greyed out on the first screen (see screenshot)screen1

I basically cannot access any multiplayer game or create a lobby anymore. I don’t get any connection issue message or so.

Xbox gamebar is fine. I tried on 3 different wifi (including tethering). I tried to reset IP address (ipconfig/release…). I tried to play on the main screen disconnected from external monitor. I tried to disable antivirus and firewall.

I run windows 10 on a surface pro, with the latest update installed from windows update.

Please fix or let me know what to do because i’ve been trying to join a game for the last two hours.

Log out from the Xbox account at the main menu. And also check if your game is up to date, lastest version is build 36202.

Hi Dededoritos,
Thank you for the tips, it worked very well. It seems that the windows store did not update the game for a few days and I was using an outdated release.

Usually it would update automatically, but this time I had to manually ask him to search for updates and update.

thx again,


1 Like

Great to hear, have a nice time playing!