Constant Freezing/lagging since latest update

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD #:**Latest build after relic hotfix - 12626487
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Constant freezing/lagging for a few seconds, then the game has to speed up to catch up to real game time.

Have previously played for 2 years without this issue, so do not believe it is anything on my side, has only occurred since latest patch

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS) (online specifically)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play ranked online match
  2. See lag

Also In unranked lobbies, have noticed server ping shows fine initially, however maybe 30 seconds after joining a lobby, my ping suddenly jumps up extremely high

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
No lag while playing

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.
server connections
However shortly after will jump from anywhere from 500-1500 ping!

Have linked a small video here showing what happens as well (sorry about the drumming video playing in the background). It happens 13 seconds in, and does this throughout the game constantly
Video Link

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Recordings do not show the issue but have linked to one

google drive link

1 Like

I’m experiencing the exact same issue - have restarted computer and game, reinstalled the game, still no luck. I only started experiencing this today (12.11.2023).

Hi, I’m also experiencing this since the latest patch. (I am also on Virgin Media!)

I am also, in the exact same way.

Have good internet, fast computer, never experienced this before.

Operating System: Windows 10 Home 64-bit (10.0, Build 19045) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: ASUS
System Model: System Product Name
BIOS: 1401 (type: UEFI)
Processor: Intel(R) Core™ i5-10400F CPU @ 2.90GHz (12 CPUs), ~2.9GHz
Memory: 16384MB RAM
Available OS Memory: 16298MB RAM
Page File: 12539MB used, 11439MB available
Windows Dir: C:\windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, no HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: 1.0.8
DxDiag Version: 10.00.19041.3570 64bit Unicode

Card name: NVIDIA GeForce RTX 3070
Manufacturer: NVIDIA
Chip type: NVIDIA GeForce RTX 3070
DAC type: Integrated RAMDAC
Device Type: Full Device (POST)
Device Key: ########################################################## Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER]
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 16181 MB
Dedicated Memory: 8032 MB
Shared Memory: 8149 MB
Current Mode: 2560 x 1440 (32 bit) (144Hz)
HDR Support: Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.685547,0.308594), Green(0.264648,0.667969), Blue(0.150391,0.057617), White Point(0.313477,0.329102)
Display Luminance: Min Luminance = 0.098400, Max Luminance = 400.000000, MaxFullFrameLuminance = 343.748291
Monitor Name: Generic PnP Monitor
Monitor Model: LG ULTRAGEAR
Monitor Id: GSM5B7F
Native Mode: 2560 x 1440(p) (143.973Hz)
Output Type: Displayport External
Monitor Capabilities: HDR Supported (BT2020RGB BT2020YCC Eotf2084Supported )
Advanced Color: AdvancedColorSupported
Driver Name: C:\windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_677da8a9230cea15\nvldumdx.dll,C:\windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_677da8a9230cea15\nvldumdx.dll,C:\windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_677da8a9230cea15\nvldumdx.dll,C:\windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_677da8a9230cea15\nvldumdx.dll
Driver File Version: 31.00.0015.4601 (English)
Driver Version:
DDI Version: 12

I’m having issues with the game stuttering/freezing briefly then catching up in ranked also.

I’ve seen a few topics about this. Some people saying it’s related to ISP, are you with Virgin Media?

I am, i historically had issues with VM so as soon as you said that i felt a cold shiver down my spine.

Other games do not experience the same latency spikes.

I am, same as WittingBobcat I have no issues with any other games, and had been playing DE for 2 years with no issues previously, only has happened in the few days since the hotfix patch

Having exact same issue since the patch. V. frustrating. I am with VM but been playing for years and never had this before. Feels like a bug.

Same issue as everyone here since last patch. Also with VM.

Same issue for me also. Does anyone have a fix and are the devs looking into this? Also with VM.

That’s a lot of people with Virgin Media and the same issue, guess that proves that something is up.

Over a decade ago I had issues with League of Legends. Had freezing/stuttering/lag/disconnections. It’s rare for me to have issues that last beyond 24 hours, but when they do, damn they’re awful.

Problem is probably on VM’s end if I was guessing though Microsoft could be to blame. I wonder if a VPN bypasses the issue by routing the traffic differently. Unfortunately I don’t have one to test currently.

Yeah I’m on VM too. FFS.

I am having this exact problem. I have been pulling my hair out for days trying everything I could think of to fix it. It started on Friday evening (10th) for me, just out of nowhere after having a perfectly fine 10x civ bonus lobby game with some friends.

I am also with Virgin Media…

My network usage in task manager keeps showing it drop to 0 before slightly spiking back up, when the lag freezes occur. I haven’t had any problems with the internet, or playing other games online.


So I’ve just tried playing with a VPN and the issue is gone. But obviously still some fix needs to be made for those that don’t have one


Somewhat good to know. Might have to sort one out so I can play later on this week if the problem persists.

Judging from the comments ball very much is in VM court to fix, unless Microsoft messed up somewhere.

1 Like

The fact that it started right after the hotfix and that I am able to play other games online without issue is rather odd.


Update: As of this morning the problem is gone for me.

The only thing that I did was uninstall the game, turn computer off last night then I reinstalled it on my main (boot) drive this morning (where it already was before). The support email reply suggested uninstalling, turn off and restart, then reinstalling.

This is the only thing I did and the only change I am aware of on my end so I have no idea if it was this that fixed it, but anyone else on Virgin Media should check to see if their lag is gone in multiplayer now. If not maybe try the above step and report back?

I am lagging since last update with (yellow color IG). I have a very fast internet and I never had any lag before…

Many other in this case ? I stopped playing for not impacting other players with my lag…

Any news regarding lag ? What has ben changed in the server infrastructure. I live in Asia and only EU servers are green.

When Im IG I get the yellow and red color… It’s unplayable for me and my team mates.

I tried with different connection and the problem is still the same.

Location : Central Asia