Constant micro-freezing and/or stuttering

As the title states, my game has been stuttering and/or micro freezing.
To better explain my issue:
My game has been working and running smoothly, I’d say perfectly up until yesterday!
The very first time I encountered the issue was during a campaign game, where I noticed that as the match progressed the game would begin to Freeze in place for about 1 second up to 5.
This is very random, and I’ve tried the following fixes to no avail:

  1. Updating all the drivers I could update in my PC.
  2. Reinstalling the game.
  3. Adding the game in the High performance list in the windows settings.
  4. Various anti-virus scans just in case.
    5.Tested other High-end games (none of them gave a single issue)
  5. Changed in-game resolution/v-sync settings.

From my tests I have gathered the following information:
-The game freezes, it doesn’t drop fps nor does it shut down. It just freezes like old games would freeze when they were about to crash.
-The game tends to lose performance and commence freezing immediately, but as more units and more commands exist within a match, the performance gets poorer and poorer, with more frequent stuttering/freezing.
-In no circumstance does the game fps worsen or performance “leaks”.

If anybody has any clue I would appreciate it, I am currently on the verge of reinstalling windows if nothing else works.

1 Like

Updating to the Public June Co-op beta fixes the issue. Which means that the current Non beta version of the game is the issue.

I’m having this issue as well. It still isn’t fixed.

Hey, do you happen to be using MalwareBytes? Or any antivirus software that has an anti-ransomware/anti-mining kit?
If so, add Age of empires 2 DE to those software’s lists of exceptions, apparently they forcibly interfere with the game. Getting rid of MalwareBytes fixed it for me

I was having this issue with both single player and multiplayer matches. Uninstalling malwarebytes fixed this issue for me after a recent patch. Something about patch 58259 made malwarebytes unhappy. uninstalling fixed it.

Edit: Thinking about this more, is there a reason malwarebytes would cause a freeze like this during both single and multi player? Seems odd that all of a sudden with a patch malwarebytes would freeze it for a second, and then allow whatever process was occurring to continue without informing the end user?

It’s the anti-ransomware toolkit that the software has, for whatever reason it hates AoE2, probably because of how CPU intensive the game is, which is also how Ransomwares tend to work, they increase CPU and HDD workload to modify your files

I am having this issue I dont have Malware bytes on my computer. My game has gotten progressively worse now It is literally unplayable online the game statturs hard. like 5-10 seconds i get the message saying I am disconnected I cant play online anymore please do something about this. This is a Microsoft product it makes zero sense that all these systems dont trust the product. I went to steam I went to everyone no one can help please this is such a trivial piece of crap issue on a Microsoft god damn product. Red bull just had a crazy huge sponsored tournament and I cant even play the game because this issue persists and doesnt go away. please help.

I guarantee 1 day of work from a level 3 support guy and a quick fix in some whitelisting list somewhere will fix this issue. It apparently has been going on for years… This is a Microsoft product. Why does this happen.