Constantly Crashing BugSplat release_10_1_0_RTM_x64

Hi guys, I am using the newest version + DLC and got crashes of the game constantly. Mostly after a few minutes, sometimes a little more. I crashed at least half of the times for the last 50 ranked games. I tried everything on Reddit and Youtube (like at least 20 fixes including re-install of Win11, clean boot, verifying integrity files, re-installing AOE4, re-installing and updating graphic drivers, admin rights, starting from RelicCardinal app, re-installing C++ Redistributables etc.) I also contacted support - so far no solution.

Here is the error message happening some minutes ago in the “eventvwr”: A crash report from application release_10_1_0_RTM_x64 has been successfully logged to www.BugSplat.com as worldsedge_cardinal-2094454.

It even crashes when I just have AOE4 in the background in the lobby after a while.
I am sure I am not the only one frustrated here. Anyone with fixes?

2 Likes

Hi,
i got the same error BugSplat-worldsedge_cardinal-release_10_1_0_RTM_x64, i get this from xbox Gamepass and Steam.

2 Likes

Hello,

I am also getting the same error. I can barely even open the game. It’s honestly amazing how bad this game is ran.

1 Like

Really hoping the support team can provide help. I’m getting the exact same error code as you all, 10_1_0_RTM_x64 and it has left me unable to play the game. The game crashes nearly every time I launch or within a few minutes of starting a game. My PC is well beyond the capabilities to play the game. I uninstalled the game countless times, updated all drivers. I’ve even gone as far as hard resetting my entire PC. Nothing works.

1 Like