Corrupted map in 1v1

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • **GAME BUILD #: last
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

The maps in 1v1 in skirmish, as in online I get the corrupted map being only in this game mode. Where I have already tried everything possible, reinstalling the game and deleting all temporary files, doing file check, etc.

When I start the game for the first time, only the first game appears normal and the others like this.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.


I have the Same problem did Reinstall my game, set everything to default nothing helped pls fix this devs.

1/3 of my games is that

I have the same problem. I was about to file a bug report with 14 similar screenshots, when I saw this.
Some additional info:

  • The bug not only affects 1v1 ranked play, but also observed (recorded) games.
  • The only way to temporarily fix it, is to restart the game, then the very first game played will not be bugged, the second game will already show garbage textures, and it will get increasingly worse the more games you play.
  • The only way to play bug free, is to restart the game after every single match.
  • I am at a disadvantage in ranked, because the map is totally confusing. The game will show ground textures in areas, which have not been discovered, and should be under the fog of war.
  • I have an AMD RX 6600 video card.

Please fix, it’s the worst bug so far.

has anyone tried updating graphics drivers?

i’ve only been doing this for 2 weeks, i reinstalled the game, completely cleaned the pc reset everything, even tested what this page said

Some of the crazier screenshots:

ye i can litterraly share ss like this every day…


( btw i have an rx 6700 )

I think you need to update the proper graphics card driver, not the newer the better, sometimes updating the graphics card driver will make the game worse, rubbish nvdia and adm.

hmm common thread seems to be amd graphics cards

1 Like

I wanted to inform you that this error has not yet been corrected. It was in the March Beta and is still there.

I would like to know if this problem is being tracked, or is it ever going to be tracked?


Tbh, it looks more like an amd driver issue


and so what, we have to continue to play with this bug ?

because the guys at amd will never try to fix this bug, and also people with amd graphics card who want to play the game will see their map bug and therefore they will simply stop playing

Dev has no contact for this kind of bug ?

Well, I have tried everything:
From hardware: Checking that the source of sufficient voltages, to the state of the cables.
To software: Controlling the GPU temperatures, disabling all programs so that there are no compatibility problems. Also disabling any overclock for both CPU and RAM, and the state of my memories.
I also disabled the game mode in Windows, deleted the drivers I had (with AMD CleanUp Utility), and re-downloaded them from the official site with their WHQL version and a bunch of other configurations, and I still have the problem.

new driver from the 7/3/2023 ( ) also don’t solve the problem

Just last week, after I changed the graphics card from 6700xt to rtx 3070, it never happened again.

Meanwhile, I also found the answer from my other computer with an amd graphics card, pre-downloaded an unofficial older version of the driver on the Internet, disconnected from the Internet to prevent the system from automatically re-downloading the driver, and used ddu (free Software) to delete the graphics card driver, and finally install the pre-downloaded driver, and then reconnect to the network.
Hope this helps anyone who has the same problem.

1 Like

Hello everyone! We have submitted a potential fix for this issue to do with 6600 XT GPUs which is now live on the Public Update Build 100.14.29779.0. Just wanted to update - and see hopefully if this issue is resolved for y’all. :cowboy_hat_face: